1. Reminder: Please use our affiliate links for holiday shopping!

No TTL with Nissin di466

Discussion in 'Olympus Cameras' started by trailguru, Jun 5, 2013.

  1. trailguru

    trailguru Mu-43 Regular

    42
    Nov 9, 2012
    Somerset, England
    I've just bought a Nissin Di466 flash to use with my E-PL3 but it only fires when the flash is set to manual. :mad:

    There's no TTL. This is in A, S and M modes with the camera's flash setting on fill in and on full.

    Any ideas how I get the flash to fire TTL? :confused:
     
  2. STR

    STR Mu-43 Veteran

    222
    May 16, 2013
    Assuming you picked up the Di466FT, and not the regular Di466 (which doesn't work with MFT TTL), it should automatically be in TTL mode when you mount it on the camera and turn it on. The little LED/mode switch button should be off. That's it. I played with the Di466FT for two days before returning it for the swiveling Vivitar DF-383-OP, so I'm going off memory here. However, it should "just work".
     
  3. Sammyboy

    Sammyboy m43 Pro

    Oct 26, 2010
    Steeler Country
    Did you set the flash settings in the SCP ?
     
  4. trailguru

    trailguru Mu-43 Regular

    42
    Nov 9, 2012
    Somerset, England
    Ref STR's reply I can't find a Di466T for sale in the UK, they're all plain Di466. But all the retail outlets claim the Di466 offers full TTL with mu-43 cameras.

    The place I bought it from describes TTL metering as E-TTL and E-TTL II. I also read a review (at Nissin Di466 Flashgun -Olympus/Panasonic Four Thirds - Wex Photographic) where the user confirms it works with the E-PL3. So I think it may be a user issue (or possibly a faulty unit).

    I set up flash mode in Live Control and tried Auto flash, Fill-in and Manual in A, S and M (speed set to 1/60 and 1/125) modes. All with the same result - the flash will only fire when the flash is set to manual.

    So any help to get it to work TTL would make my day (or night).
     
  5. arch stanton

    arch stanton Mu-43 Veteran

    414
    Feb 25, 2012
    London
    Malc
    Hi there, E-TTL sounds like the canon TTL version?
    If you bought the canon version of the flash it will not TTL on an Olympus camera. You need the Four-thirds version of the flash:
    http://www.amazon.co.uk/Nissin-Di46...e=UTF8&qid=1370524899&sr=8-2&keywords=di466ft

    Sadly, each manufacturer's TTL signal system is different (despite sharing the acronym), the same flash won't talk canon TTL, nikon TTL and 4/3 TTL.
     
  6. trailguru

    trailguru Mu-43 Regular

    42
    Nov 9, 2012
    Somerset, England
    It's definitely the mu43 version - unless all the packaging etc is wrong.
     
  7. STR

    STR Mu-43 Veteran

    222
    May 16, 2013
    Then swap it out.
     
  8. Ranger Rick

    Ranger Rick Mu-43 Veteran

    228
    Apr 11, 2009
    Tempe, AZ
    Rick
    I have what I assume is the same one- bought it from Cameta; says for both FT and MFT, nothing re FT designation. Use on EM-5.

    Have found it is a bit demanding of being perfectly seated in hotshoe and tightened/locked in, otherwise it doesn't work. Try this and see if it solves the problem. Wiggle it a bit...
     
  9. inkista

    inkista Mu-43 Veteran

    332
    Jan 13, 2012
    San Diego, CA
    I am so sorry for asking this question. Really. But I saw someone post this as their fix for a similar problem on another board, and feel the need to cover all the bases. Apologies in advance.

    Are you sure you haven't mounted the flash on the camera backwards?
     
  10. Sammyboy

    Sammyboy m43 Pro

    Oct 26, 2010
    Steeler Country
    Did you go into the SCP and then to the flash sub-menu and select TTL ??
     
  11. trailguru

    trailguru Mu-43 Regular

    42
    Nov 9, 2012
    Somerset, England
    Ranger Rick was right - the flash wasn't pushed fully into the hotshoe so that all contact points were engaged. When pushed fully home there's a distinct click and, behold, the TTL mode is available.

    Thanks for everyone's help.

    BTW I returned the flash, not because the lack of TTL, but because this model doesn't have a swivel head which really restricts its usefulness.
     
  12. cstevens

    cstevens Mu-43 Veteran

    411
    Feb 11, 2010
    UK
    Surprised they gave you a refund based in you didn't read the specs.....clearly it doesn't swivel.

    But it does ttl well it does on the OMD anyway
     
  13. shaolinmonk

    shaolinmonk Mu-43 Veteran

    242
    Aug 31, 2013
    Toronto Canada
    i tried one the other day and it didn't seem to work either on my em5... anyone else having this issue ... could it be the new firmware?
     
  14. datagov

    datagov Mu-43 All-Pro

    Dec 2, 2012
    New York
    I bought one a year ago and it didn't work on my em5 either. I returned it and got a yongnuo 460 and taught myself to do manual flash. It's easy after some trial and error and far cheaper than ttl flashes.

    Sent from my SCH-I535 using Tapatalk
     
  15. yakky

    yakky Mu-43 Top Veteran

    662
    Jul 1, 2013
    I just picked one up from eBay, seems to work very well on my EPL3 so far. Great deal for $115.
     
  16. WasOM3user

    WasOM3user Mu-43 Veteran

    458
    Oct 20, 2012
    Lancashire, UK
    Paul
    I found that with my EM-5 I had to clean the side contacts on the hot shoe (camera) before my Nissin would work almost as though there is a layer of something on the contacts as a result of the moulding process.

    Just used a cheap nail emery board cut down to suit.
     
  17. owczi

    owczi nareteV 34-uM

    This happened to me with this flash more than once. One of the reasons why could be that as you turn the locking ring to unlock it, the locking pin rises but in the very last degrees of the turn it drops a tiny bit again, so it may catch a little.

    Sadly Nissin don't make any other models in the FT version, I love my 466 but indeed swivel and RC mode would make it THE choice vs. Olympus and Metz.
     
  18. billbooz

    billbooz Mu-43 Regular

    198
    Jan 23, 2014
    Lynchburg, VA USA
    William H. Booz
    Know these posts are from year ago, but, STR, if you're still around...does the Vivitar DF-383-OP flash for Olympus SLRs work with Olympus m4/3 (want to use with E-M10) cameras in TTL mode?