1. Reminder: Please use our affiliate links for holiday shopping!

Nikkor f1.8 50mm and GF-2

Discussion in 'Adapted Lenses' started by cph, May 17, 2011.

  1. cph

    cph New to Mu-43

    6
    May 17, 2011
    Hi there

    I'm new to photography but wanted to experiment a little.

    I've bought the above lens and it clicks on very nice on the camera and I can see through the lens and focus and change the aperture.

    But when I press the 'shoot button' i get an error message that no lens is attached - help...I've tried in different shooting modes.

    Obviously I'm doing something wrong, but what?

    Br

    Jens
     
  2. mzd

    mzd Mu-43 Veteran

    241
    Nov 30, 2010
    Wisconsin
    Yes, you need to go into the custom menu and enable "shoot without lens." This is turned off by default.
     
    • Like Like x 2
  3. cph

    cph New to Mu-43

    6
    May 17, 2011
    Thx a lot I would never have figured that out on my own.

    Just took the first pic :smile:

    Hope to show some god pics in here.

    BR

    Jens

    Now that I've set up the mode, I guess I should make like a special mode for shooting with this lens?
     
  4. dko22

    dko22 Mu-43 Regular

    163
    Jul 26, 2010
    Stuttgart, Germany
    I've got the AIS version of this lens and really like it with my GH2. Sure you'll enjoy it.
     
  5. cph

    cph New to Mu-43

    6
    May 17, 2011
    Hi Dko

    Can I ask you which settings you use for this lens? In terms of ISO and WB?

    Br

    Jens
     
  6. icy_se7en

    icy_se7en Mu-43 Regular

    70
    Apr 17, 2011
    Hmm on my G1 it dont show any picture without a panasonic lens attached just comes up saying please use the correct lens or something before I turn the shoot without lens on, like before pressing the shutter button it comes up with the message unless they changed it I dunno