New E-P3 owner

Discussion in 'Olympus Cameras' started by Matt b, Jul 7, 2013.

  1. Matt b

    Matt b New to Mu-43

    Jan 10, 2011
    Hi all.
    Pop into my local shop to have a look at a OM-D but it just didn't feel right to me. Asked if they had any E-P5 yet but not in till this week but he said he had 1 E-P3 left. Had a play with it using my 45mm and it just felt right. He offered it to me on a really good body only deal to clear it and gave me a good trade in on my G2. After using it over the weekend its feeling good but I have one question to ask and I'm sorry if this has been asked before. Is the IS noisy on these. If I take a long shot there is a almost mechanical noise while it is taking the exposure. Turn the IS off and it is silent. This is the thirst body I have had with IBIS (canon 450D,G1,G2 and GF1) so not sure if this is normal.
  2. gochugogi

    gochugogi Mu-43 Veteran

    Jul 8, 2013
    Oahu, gathering place of many cars
    Real Name:
    Peter Gunn
    Matt, I have an E-P3 and can't hear the stabilization working. I mainly use the EVF so my face is very near the camera. I can hear IS working in some of my Canon lenses if I'm in a quiet room.
  3. gugarci

    gugarci Mu-43 Veteran

    Jul 8, 2012
    Lyndhurst, NJ
    Real Name:
    I've never heard the IS kick in on my E-P3. I fit makes any noise it must be really soft because in every day usage I've never heard it go on.
  4. Matt b

    Matt b New to Mu-43

    Jan 10, 2011
    Think I will take it back this weekend and see what they say. Thanks for your help.
  5. Marc0

    Marc0 Mu-43 Regular

    Jun 20, 2012
    Real Name:
    hi, I also have an ep3 but it's totally silent.
  6. snkenai

    snkenai Mu-43 Top Veteran

    Sep 5, 2010
    Mine does it on long shots. On short shots it is so quick that shutter sound covers it.
  7. drd1135

    drd1135 Zen Snapshooter

    Mar 17, 2011
    Southwest Virginia
    Real Name:
    Of course, many of us are old guys and our hearing might be suspect.
  8. RevBob

    RevBob Super Moderator

    Jun 4, 2011
    NorthWestern PA
    Real Name:
    I haven't noticed noise with mine, I'll have to pay more attention.
  9. RobR

    RobR Mu-43 Regular

    Jun 19, 2013
    Connecticut, USA
    Real Name:
    Robert Reinhardt
    Well, I can't confirm anything about the E-P3 specifically, but the IBIS in my E-PL2 (uses the same mechanism) definitely makes noise. I can only describe it as a soft mechanical grinding or perhaps some rocks being ground together. A good test to troubleshoot this is to mount the camera on a tripod [or a table] and set it for a 1 second exposure with the IBIS on. If you don't hear much, then it definitely is the IBIS.
    Congrats on the new purchase and welcome to the Olympus family!

    P.S. If I remember, I'll try to take a video of what mine sounds like and post a link to it here.
  10. Matt b

    Matt b New to Mu-43

    Jan 10, 2011
    Yes mine does it on long shots. Short shots you only here the shutter.