My Faulty M1.

Discussion in 'Olympus Cameras' started by emmbeedee, May 15, 2018.

  1. emmbeedee

    emmbeedee Mu-43 Regular

    118
    Nov 11, 2017
    So a week ago my M1 died, and no matter what I tried, it would only click, but not turn on. I tried a number of things: new batteries, different memory cards, no memory card. Nothing changed, so I called Olympus.

    They suggested I send it in, and for $180 US would fix it, no matter what the problem was.

    I did send it to them on the 7th, and called Monday when their "Customer Service and Repair Center web page said it had been received, and was "waiting for approval". I approved the repair and paid with my credit card.

    Today I got notice that the camera is on its way back to me after this was done:

    REPLACED SHUTTER ASSEMBLY, REAR DIAL ENCODER, EYE CUP. RESET STRAP EYE LET. CLEANED IMAGE SENSOR AND CAMERA BODY. ADJUSTED SHUTTER SPEED, IMAGE STABILIZER, IMAGE SENSOR. RESET CAMERA BODY TO FACTORY SETTING. UPDATED FIRMWARE,TESTED AND CLEANED.

    Seems like a bargain to me, and amazingly fast!

    It's too bad it broke but with how complicated these things are, it's surprising they're as reliable as they are.

    Thanks Olympus.
     
    • Like Like x 9
    • Agree Agree x 1
  2. jp300

    jp300 New to Mu-43

    4
    Mar 23, 2014
    Definitely a bargain -- money well spent!
     
    • Agree Agree x 3
    • Like Like x 1
  3. Carbonman

    Carbonman Mu-43 All-Pro Subscribing Member

    Jul 10, 2014
    Vancouver BC
    Graham
    It's nice that they check everything when it's serviced. I sent mine in with a shutter problem and they went over everything as well, similar to what they did with yours.
     
    • Like Like x 1
  4. DynaSport

    DynaSport Mu-43 Hall of Famer

    Jan 5, 2013
    Dan
    That is a great deal!
     
    • Like Like x 1
  5. emmbeedee

    emmbeedee Mu-43 Regular

    118
    Nov 11, 2017
    Unfortunately WiFi is not working so it has to go back. [​IMG]

    Display says: WiFi Starting up. WiFi Shutting Down.

    Probably forgot to plug the antenna in or something.

    Damn.
     
    • Sad Sad x 1
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.