My brand new E-m5 MKII is really sleepy...

Discussion in 'Olympus Cameras' started by RenaudVL, Feb 26, 2015.

  1. RenaudVL

    RenaudVL Mu-43 Veteran

    Mar 21, 2011
    Ok, just got my MKII yesterday, took it for a spin and it goes into sleep more almost instantly after the shutter was realest, or even just by looking at it... I have change the setting to 5 minutes shutdown and 3 minutes to sleep, also tried sleeping mode off. Still does it...

    EDIT: Just find out that it does not do it in live vue mode on the LCD!!!

    Anybody knows or have seen this also?
    Any clues?


    Last edited: Feb 26, 2015
  2. barry13

    barry13 Super Moderator

    Mar 7, 2014
    Southern California
    Real Name:
    Hi, the whole camera is sleeping, or just the rear LCD goes blank?

  3. RenaudVL

    RenaudVL Mu-43 Veteran

    Mar 21, 2011
    Hey Barry,

    The LDC and the view finder goes blank after about 1.5 second even if the sleep setting is on off.
    When I keep my eye to the view finder it does stay on, I just find it strange, my E-M1 doesn't do that...

    Just need to make sure it is not a glitch...
  4. ToxMox

    ToxMox Mu-43 Rookie

    Oct 9, 2012
    Check that the Quick Sleep setting is off.
  5. RenaudVL

    RenaudVL Mu-43 Veteran

    Mar 21, 2011
    :confused: Damn, I feel stupid :confused:
    Did go through the menu a few time...
    Mist that one, it is the very last one on the list...

    Thanks guys o_O
  6. ToxMox

    ToxMox Mu-43 Rookie

    Oct 9, 2012
    For some reason they put Quick Sleep in the Utility Menu instead of the Sleep Menu. Strange.
    • Agree Agree x 1
  7. jonlong

    jonlong Mu-43 Regular

    Oct 25, 2013
    Olympus menus are poorly laid out. It always takes me too long to find related options.
  8. jnewell

    jnewell Mu-43 All-Pro

    Jun 23, 2011
    Boston, MA
    The mercy is that in most cases, once you find the setting and figure out how you want it, you can leave it alone. The rest can hopefully be dealt with with MySets or button assignments.
  9. ymc226

    ymc226 Mu-43 Rookie

    Feb 24, 2015
    New Jersey
    Thanks. That helped me realize that I could turn off quick sleep. In actuality 3 seconds is too short to try to pick out what you need to change from the LCD menu.
  10. opticagent

    opticagent Mu-43 Rookie

    May 14, 2013
    Nashville, TN
    Agreed! Just got my MKii today and wondered why it was acting so sleepy. Now it's oh so speedy!!! Big thanks!
  11. T N Args

    T N Args Agent Photocateur

    Dec 3, 2013
    Adelaide, Australia
    Real Name:
    call me Arg
    Is Quick Sleep the new (?) battery saver mode that gets mentioned for this model, ups battery rating from 310 to 750?