My 20mm wont focus :-(

Discussion in 'Native Lenses' started by andyph, Dec 31, 2013.

  1. andyph

    andyph New to Mu-43

    Sep 21, 2012
    This doesn't seem to be a widely reported problem (can only see here: Started out intermittently, but now happens all the time for me.

    Upon powering up, the lens makes a noise (not a normal one) for about a second, then will refuse to focus (AF or MF for that matter). I've tried it on different cameras, and the results are the same.

    I suspect there is some grit or dirt in the mechanism. I'm out of warranty, so I reckon my options are:

    1) Open it up and try to clean it (apparently it's quite simple to get at: ). Anyone tried this?
    2) Find somebody more competent than me to diagnose & fix (any UK-based recommendations?)
    3) Sell it on ebay for spares + repairs

    Any advise would be welcome
  2. mr_botak

    mr_botak Mu-43 Veteran

    Dec 4, 2011
    Reading, UK
    Real Name:
    That's unfortunate. I suspect option 2 will likely cost more than the lens is worth, and I doubt you'd get much interest in 3, so if you feel competent your best option might be to open the lens and check for a loose connection or try to clean.
    • Like Like x 1
  3. andyph

    andyph New to Mu-43

    Sep 21, 2012
    I think you may be right. It's an excuse to get some proper screwdrivers to do this sort of thing.
  4. HarryS

    HarryS Mu-43 Top Veteran

    Jun 23, 2012
    Midwest, USA
    • Like Like x 1
  5. JoeV

    JoeV Mu-43 Regular

    Aug 22, 2012
    Albuquerque, New Mexico, USA
    Real Name:
    Joe Van Cleave
    Before you try "fixing it" yourself, check if you have a filter or adapter ring threaded onto the front of the lens. If so, take the filter or ring off, then cycle the power to the camera off and back on, then check operation.

    My lens intermittently did exactly what you're describing for several years, because a 46-49mm step-up ring I had attached to the lens had 46mm threads that were a bit too short, meaning that if the adapter ring was threaded tightly onto the lens, it would prevent the focus mechanism from moving the front lens element, which it tries to do upon power-up.

    I had thought the problem was the design of the lens, until by happenstance I replaced the ring with a new one of a different brand and the problem disappeared! Appearantly the tolerances of the front filter threads are a bit on the shallow side with this lens, and not every brand of filter or step-up ring will work.

  6. andyph

    andyph New to Mu-43

    Sep 21, 2012
    Harry, thanks for that - very helpful

    Joe, thanks, but there's nothing attached to the filter threads at the moment. I have used a third-party hood in the past, so I hope that hasn't caused any lasting problem.
  7. andyph

    andyph New to Mu-43

    Sep 21, 2012
    Update - a couple of tries. I followed this thread here:

    I got as far as removing the focus motor, but didn't disassemble the gearbox (it didn't feel rough when I turned it by hand). I removed the focussing ring (the internal one, not the focus by wire one), and cleaned it up, as well as the surrounding moving parts. Put it all back together and to my amazement, the thing actually worked!

    Most worrying moment was removing the ribbon cable tabs - I was trying to unclip them from the wrong end and nearly wrecked the circuit board. Those things are fragile from previous experience.

    Admittedly, it still doesn't sound 100% right though. I'm sure there's a bit of sand or grit in there, but either it will work its way out or I'll have to go through the process again. I've never been too precious about my gear, but maybe this lens is deserving of a bit more TLC (certainly compared to the 14mm which I feel is a bit more robust).
    • Like Like x 2