1. Reminder: Please use our affiliate links for holiday shopping!

Metering on GF3 w/15mm Body Cap Lens

Discussion in 'Native Lenses' started by Replytoken, Dec 11, 2012.

  1. Replytoken

    Replytoken Mu-43 Hall of Famer

    May 7, 2012
    Puget Sound
    Ken
    I picked up a 15mm body cap lens this weekend during an Olympus event at my local dealer. I had been considering one for my GF3 for a while for an ultra portable camera. I know that the Olympus reps said that the lens did not pass any information along to the camera, but I thought that they also stated that you could put the camera in Aperture mode, and it would automatically set the shutter speed for you. My GF3 meters with the lens, but does not adjust the shutter speed. Was there a miscommunication with the Olympus rep? Does this lens work in any automatic mode with any body?

    --Ken
     
  2. Zariell

    Zariell Mu-43 Top Veteran

    535
    Sep 28, 2012
    Bountiful, UT
    I don't own a Panasonic camera, but my E-M5 and E-P3 both meter just fine in Aperture priority mode.
     
  3. MikeR_GF1

    MikeR_GF1 Mu-43 Veteran

    I don't know if the GF3 has the same options in its setup settings as the GF1, but to work with adapted lens (no electrical connection, just like the body cap lens), I needed to set the camera to work without a lens. Then "A" Aperture priority works, allows the camera to meter and set shutter speed.
     
  4. Replytoken

    Replytoken Mu-43 Hall of Famer

    May 7, 2012
    Puget Sound
    Ken
    I did set the camera to shoot w/o a lens, but it does not appear to be automatically setting the shutter based on what it is reading in A mode. I asked the question because I thought that the reps siad that even though no data is passed for recording, the camera body would work in Aperture priority with the lens. I will double check my settings to make sure nothing else is causing the camera to not function automatically. Very weird.

    --Ken
     
  5. battleaxe

    battleaxe Mu-43 Top Veteran

    I think it should because with my G2 and GF3 with legacy lenses I can get the camera to meter just fine in A mode.
     
  6. Replytoken

    Replytoken Mu-43 Hall of Famer

    May 7, 2012
    Puget Sound
    Ken
    Ok, I removed the lens and re-set it on the GF3 and now it is now working fine in Aperture priority. Go figure! Now, if we could just get a bit of sun so I can try shooting a few test shots.

    --Ken