Meaningless warning on switching on G1 power.

Discussion in 'Panasonic Cameras' started by Dave Reynell, Aug 8, 2015.

  1. Dave Reynell

    Dave Reynell Guest

    For some time now I have been reading the following notification/warning displayed across the viewfinder of my ageing Panasonic DMC G1 every time (or almost everytime) I power the camera up : "Mode dial is not in the proper position".

    Since I shoot using the so-called "Intelligent Auto" mode for about 90% of my photographs, with shutter priority the remaining 10%, my question is, What's not "proper"?.

    If there are still any G1 users out there, I'd be interested to learn if they have had, or are still having, similar messages pop up in the viewfinder.

    • Funny Funny x 1
  2. dwig

    dwig Mu-43 Top Veteran

    Jun 26, 2010
    Key West FL
    I still shoot with a G-1, though usually in the "P" mode rather than the "iA" mode, and have yet to see that warning. It seems to be a warning that something somewhere is not compatible with the "iA" mode. It could point to a (intermittently) faulty communication link with the lens, possibly dirty contacts in the lens mount. Just a guess, but it is simple enough to take the lens off and wipe the lens and body contacts with a clean cloth.
  3. Klorenzo

    Klorenzo Mu-43 All-Pro

    Mar 10, 2014
    I think that the camera thinks that the mode dial is physically in between two different positions. Probably a false contact.
    Gently turning the dial for a couple of rounds in both directions could help to clean the contacts.
  4. Dave Reynell

    Dave Reynell Guest

    Many thanks for your suggestions. I spun the dial around (gently) several times and it seems to have done the trick.

    • Like Like x 1