Maximal Power battery

Discussion in 'Accessories' started by dulaney22, Aug 27, 2010.

  1. dulaney22

    dulaney22 Mu-43 Regular

    106
    Aug 18, 2010
    Hey guys, just giving a heads up that you may want to think twice about ordering one of these. I got one a couple days ago and it won't charge. You put it in the charger and it just blinks. I've emailed the company several times, but to no avail.

    Anyway, I may have just gotten a dud, as I have read of numerous reports of people happy with their product. Unfortunately, my $10 or so was wasted it appears.
     
  2. everythingsablur

    everythingsablur Mu-43 Veteran

    412
    Aug 4, 2010
    Toronto, ON
    What is this a battery for? PEN? G-series?
     
  3. dulaney22

    dulaney22 Mu-43 Regular

    106
    Aug 18, 2010
    Sorry, it's for PEN. E-P1 is what I have. Guess it fits E-P2 as well.
     
  4. everythingsablur

    everythingsablur Mu-43 Veteran

    412
    Aug 4, 2010
    Toronto, ON
    Sounds like you have a dud. Oly cameras generally don't have a problem with knock-off batteries, where Panasonic has encoded their batteries so you "need" to use OEM batteries (though some 3rd party manufacturers are cloning this now too; just means you can't just buy the cheapest ones you find).

    Since the unit won't even charge, I suspect it's a bad battery somehow. Hope you can get it replaced!
     
  5. Pilgrim

    Pilgrim New to Mu-43

    FWIW my sample Maximal Power works great in my EPL1, maybe greater endurance than the original one. The only downside is that when it begins to deplete gives almost no warning. When the low bat sign appears it's already dead!
    Regards,
    Ezequiel
     
  6. Hyunkie

    Hyunkie New to Mu-43

    9
    Aug 20, 2010
    I have the same battery and I would that it lasts longer than the original one but I do have the same issue about the battery indicator. :rolleyes:
     
  7. VisualFX

    VisualFX Mu-43 Regular

    38
    Aug 20, 2010
    I have four of the BLS-1 Maximal Power for my E-PL1, that I bought for an upcoming trip. They all charge and work fine and seem to last a long time, but I am having same problem. Go into the Utility menu and adjust the battery level. I am now trying +1, and battery indicator does work somewhat better for me. I think you adjust it to +1 or +2 for larger capacity battery.

    Also I have got two different batches of those batteries, each with a different label. One says 7.2V and other 7.4V. But all say BLS-1 at 1800mAh. I'm not sure why the voltages are inconsistent for same battery model. The OEM battery says 7.2V 1150mah.
     
    • Like Like x 2
  8. dulaney22

    dulaney22 Mu-43 Regular

    106
    Aug 18, 2010
    Wanted to update this thread. I sent the battery back and received a refund, along with a new battery and apology note. This one has been working great for a month plus. Don't know what was up with the first, but they definitely made up for it.