LX100 and RF-603's

Discussion in 'Panasonic Cameras' started by DekHog, Aug 22, 2015.

  1. DekHog

    DekHog Mu-43 Top Veteran

    601
    May 3, 2011
    Scotland
    RF-603's seem quite topical on here at the moment!

    Does anyone know if the hotshoe on the LX100 is a totally different size than standard, as my RF-603's only slide about a third of the way into it then come to an abrupt and very firm halt?

    I did try a little bit of forward pressure but didn't want to push too hard...... bit of a bummer if they don't actually fit.

    I ended up using the LX100 flash and the off camera flashes in S1 mode which worked fine.....
     
  2. DekHog

    DekHog Mu-43 Top Veteran

    601
    May 3, 2011
    Scotland
    Ah, it's ok. I just went back to it and used brute strength and ignorance and it snapped into place and works fine....... Tight fit!!
     
    Last edited: Aug 23, 2015
  3. Engawa

    Engawa Mu-43 Regular

    45
    May 23, 2014
    I'm glad to hear it fit!
    Out of curiosity, what's the max sync speed you can get with that combo?
     
  4. DekHog

    DekHog Mu-43 Top Veteran

    601
    May 3, 2011
    Scotland
    I just had it set manually to 1/250th (force of habit!) but will do a couple of tests today and let you know....... :) 
     
  5. DekHog

    DekHog Mu-43 Top Veteran

    601
    May 3, 2011
    Scotland
    LX100 with RF-603 and YN-560 III

    100% success at 1/800th. Only about a 40% success rate (black frames) at 1/1000th. Flash doesn't trigger using electronic shutter, but I think this is by design......
     
  6. Engawa

    Engawa Mu-43 Regular

    45
    May 23, 2014
    Thanks for testing it and reporting the results!
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.