1. Reminder: Please use our affiliate links for holiday shopping!

LX-100 sensor malfunction?

Discussion in 'Panasonic Cameras' started by HateCameras, Jul 22, 2016.

  1. HateCameras

    HateCameras New to Mu-43

    4
    Jul 22, 2016
    Camera behaves like it's getting too much light. Can't focus.

    Everything else works fine I can take the picture and it saves what you see on the screen to the SD card.

    Help :(
    (out of warranty I guess?)
    I bought it in June 2015 (UK) I could swear it said 24months warranty,
    When I go to panasonic support page it only says 12 months for digital cameras?
    I feel a bit dissapointed as that would mean I'm a month out of warranty...

    IMG_20160722_160841.
     
  2. panamike

    panamike Mu-43 All-Pro

    Jul 5, 2016
    Lincolnshire UK
    I know the UK site says 12 months but doesn't it go to 24 months if you register it.
     
  3. HateCameras

    HateCameras New to Mu-43

    4
    Jul 22, 2016
    I will join a raffle to win a camera that's all of the benefits of registration as far as I can see...

    I contacted Amazon technical support but unfortunately they say it's out of warranty, they redirected me to Panasonic UK support :(
     
    Last edited: Jul 22, 2016
  4. panamike

    panamike Mu-43 All-Pro

    Jul 5, 2016
    Lincolnshire UK
  5. HateCameras

    HateCameras New to Mu-43

    4
    Jul 22, 2016
    That's only live since April. Not valid for 2015


    OK nevermind it was one of the ribbon cables or dirt on the motherboard.
    I opened up the camera myself, reconnected everything, put it back together and it's working fine now. Go figure...
     
    Last edited: Jul 22, 2016
    • Like Like x 1