LUMIX Pro Services?

Darmok N Jalad

Temba, his aperture wide
Joined
Sep 6, 2019
Messages
1,998
Location
Tanagra (not really)
So when I waffled back and forth a few months ago on camera bodies, I ended up getting a new G9 about 2 months back. When I went to register with Panasonic, I see they now have a new way of managing your account--LUMIX Professional Services, with 2 tiers, free, and paid. Naturally, Mr. Cheapskate just opted for the free plan in order to register for my 3 year warranty extension that Panny has been offering for years now. A few weeks later, I got a letter in the mail from Panasonic with a black LPS card, and a note saying a welcome kit would be sent to me shortly. No critical info was on the letter, so I tossed it. I really didn't think much of it, figuring it'll be another letter or something.

Then something odd occurred where when I created my account (or when I thought I did anyway). My password manager either didn't store my password, or it never gave me the option. Either way, I needed to reset my password in order to sign in. Problem was, password reset on the website didn't work because I didn't have my Member ID number. I reached out to Panasonic support via webform, and in a few days I got a response from a rep at LPS. The rep stated that I indeed needed my Member ID to sign in, and that it was in my welcome kit. I guess I totally forgot one was supposed to be sent, but I never got one. No worries, as they said they would just send another out. Today, I got a FedEx alert stating a package from FL was on the way, and sure enough, it's from "Panasonic Service Center," and around 2lbs! What the heck is coming from Panasonic? Anyone know? When I registered my first G9, it was just on the Panasonic website, which you can still do register for the 1 year warranty. Now we get a welcome kit? Now I'm curious.
 

Darmok N Jalad

Temba, his aperture wide
Joined
Sep 6, 2019
Messages
1,998
Location
Tanagra (not really)
I'm starting to suspect they sent me the Platinum Membership kit by mistake. I just signed up for the Red membership, which is free. The site makes it sound like all I should have gotten was a card, which I did, but it didn't have a member ID on it. I guess we're off to a rocky start? Might need to follow up with that LPS rep.
 

Brownie

Thread Killer Extraordinaire
Joined
Sep 3, 2018
Messages
4,159
Location
SE Michigan
Real Name
Tim
They still think I own an S1. It's been that way since I registered my G9. They invited me to all of the S1 Gee-Whiz podcasts and Q&A sessions. I'm afraid to tell them they have it wrong, who knows what they'll sign me up for.
 

Darmok N Jalad

Temba, his aperture wide
Joined
Sep 6, 2019
Messages
1,998
Location
Tanagra (not really)
Well, I tried to clear things up with LPS, saying I have a package coming from them via FedEx. The rep replied saying I should be getting just a card. I don't know what to think at this point. Maybe they tied it around a brick so I wouldn't lose it this time?
 

Latest threads

Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Mu-43 is a fan site and not associated with Olympus, Panasonic, or other manufacturers mentioned on this site.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Forum GIFs powered by GIPHY: https://giphy.com/
Copyright © Amin Forums, LLC
Top Bottom