Lumix 7-14 on GH4, any purple blob?

LowTEC

Mu-43 Regular
Joined
Jul 18, 2012
Messages
186
Location
Hong Kong / Raincouver
I posted in Panasonic Camera section https://www.mu-43.com/showthread.php?t=65170 but I want to focus on the 7-14 lens discussion here.

I have been using my beloved 7-14 f4 on my E-M5 and EPL5 on every travel occasion, but the severe purple blob issue really drives me crazy sometimes. (I wouldn't want to explain the difference between normal flare vs serious purple blob happens to EM1, EM5 and GH3, if you don't know the difference, be adviced to take a look at these links https://www.mu-43.com/showthread.php?t=45013 and http://www.cameralabs.com/reviews/Pa...f4_H_F007014E/ for references). For those of you lucky guys who own both the GH4 and the panny 7-14mm, any purple blob occurs like on EM1, as mild as on GX7, or completely avoided like on older Panasonic sensors? Thanks and appreciated
 

RRRoger

Mu-43 Regular
Joined
Apr 28, 2014
Messages
57
Location
Monterey Bay
I tried the 7-14 f/4 on my GH3.
I did not notice any purple blobs.

What I did not like was the poor/low light performance.
That is why I sent mine back.
What I want is an f/2.8 or faster Lumix to match my 12-35 and 35-100.
 

Latest posts

Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Mu-43 is a fan site and not associated with Olympus, Panasonic, or other manufacturers mentioned on this site.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Copyright © 2009-2019 Amin Forums, LLC
Top Bottom