1. Reminder: Please use our affiliate links for holiday shopping!

"Locking up of OM-D"

Discussion in 'Olympus Cameras' started by LeeC, May 15, 2013.

  1. LeeC

    LeeC New to Mu-43

    6
    Feb 7, 2013
    Iowa, USA
    I have had the OM-D about 3 months and it occasionally "locks up" the only way I can get it to work again is to shut it off and remove the battery, then re-install the battery and power it up again. I have the additional grip that holds an additional battery and the hand strap and it is a real pain because you have to un-thread the hand strap to remove the battery in the camera itself. Has anyone else experienced this? LeeC
     
  2. Joe King

    Joe King Mu-43 Regular

    137
    Mar 3, 2013
    Dublin, Ireland
    This happens to me from time to time with either the Panasonic 20mm or the Panasonic 12-35mm lenses attached. It's a well-known issue, at least with the 20mm, but I am not aware of any resolution. It seems to be that the camera can't be roused from sleep mode for some reason. I generally solve it by switching off the OM-D rather than letting it sleep (not so much because of this happening but as a means to preserve the battery life).
     
  3. LeeC

    LeeC New to Mu-43

    6
    Feb 7, 2013
    Iowa, USA
    Thank you Joe!

    I have 2 lenses for the OM-D both Olys 12-50 and 70-150?. After your post I got to thinking back when this happened and it was always with the 12-50, that is the lens I use most, and it was after a pause in shooting, so maybe the no wake up scenario is valid. LeeC