1. Reminder: Please use our affiliate links for holiday shopping!

Lightroom Bug - missing files?

Discussion in 'Open Discussion' started by robbie36, Oct 11, 2013.

  1. robbie36

    robbie36 Mu-43 All-Pro

    Sep 25, 2010
    Bangkok
    rob collins
    Ok. No need to panic yet....

    But here are 2 facts...
    1) A bunch of my Lightroom photos went missing - 529 to be exact. Worst of all potentially they were most important photos like edited tifs.
    2) There is a known bug in Lightroom 5.0 (that continues in 5.2) that can cause you to lose your files....

    See here...
    http://regex.info/blog/2013-06-10/2268
    Anyone who knows of J. Friedl will know he doesnt make stuff up.

    Now whether my missing files and this Lightroom bug are connected is highly debatable. Maybe I just screwed up somewhere - it is very possible. It isnt the end of the world as 95% are properly backed up (even though I am not sure when they went missing.)

    There was a 52GB difference between my on computer files and my back up.

    Anyway there is a quick and easy check you can do in Lightroom to see if you are missing any files. Go to grid view, select all photos then library - find all missing photos. None missing ... no worries.

    Even if you are not missing any photos I suggest that you take the precaution mentioned in the blog. Namely in 'grid view' select your photos for 'export' 'edit in' 'publish' through the filmstrip rather than within the grid itself
     
  2. meyerweb

    meyerweb Mu-43 Hall of Famer

    Sep 5, 2011
    Remember that lightroom is just indexing your files. Unless you think LR actually physically deleted them, which seems unlikely, they're probably still on your disk.
     
  3. robbie36

    robbie36 Mu-43 All-Pro

    Sep 25, 2010
    Bangkok
    rob collins
    Actually I do understand that. In other words just because Lightroom cant find them(!) doesnt mean they are not on my computer somewhere.

    But these files have gone and were no longer on my computer. I did a windows search of several files over both my hard disks. They were not on there at all.

    In other words they were definitely deleted from my hard disk. The fact that my library still shows them without the underlying file, seems to indicate to me that I deleted files I didnt mean to - which is a sign of the bug.