1. Reminder: Please use our affiliate links for holiday shopping!

Lightroom 4 went nuts...

Discussion in 'Image Processing' started by Zariell, Jan 3, 2013.

  1. Zariell

    Zariell Mu-43 Top Veteran

    535
    Sep 28, 2012
    Bountiful, UT
    I had Lightroom start doing some weird crap on me today. I keep a triple redundancy system, when I import my files from the memory card, a copy is kept on my HDD, a copy is moved to a network HDD, and then every month I have an offsite HDD that I download the files to that is kept off site in case of when a catastrophic fail happens :p

    Anyway today I was setting up things for the new year and found that LR, had decided to make all the file connect to the HDD that is kept offsite, so even though the files were where it could see them, I got nothing but question marks and nasty messages telling me that the files had been moved. I solved the problem by restoring from a backup LR that I had made a couple of days ago, but I have yet to figure out why it suddenly decided that the files werent where they have always been. I blame the gremlins but so far they arent talking.
    :frown:
     
  2. Fmrvette

    Fmrvette This Space For Rent

    May 26, 2012
    Detroit, Michigan
    Jim
    Hi Zariell!

    By default, Lightroom opens the most current catalog at startup. Could you have left the HDD catalog open the last time you used LR4?

    Adobe Photoshop Lightroom 4 * Creating and managing catalogs

    I had friend who uses Elements and after being told not to used Windows Explorer to move massive numbers of photos around on his computers internal hard drive. He experienced some of what you describe - Elements knew where the photos were last located, and when they were not in the same location things got very interesting very quickly :rofl:. I had to do a house call to get everything back in order.

    (It's really good that you keep copies off site - I've been trying to talk one of my friends into do that, but it's "too much trouble"...so I'm waiting for The Day. :biggrin:).

    Regards,

    Jim
     
  3. Zariell

    Zariell Mu-43 Top Veteran

    535
    Sep 28, 2012
    Bountiful, UT
    I think something got corrupted, I don't move files, I just copy them, what was weird is it was telling me there were no copies of the files in places where I could verify they were still right there. It's probably bad of me but the backups that I make I do not have in the Lightroom database, I figure if and when the HDD fails, I can just use a backup of the Lightroom DB after I copy the files back onto the new HDD, I assume if it sees the files in the same places it "shouldn't" be a problem, I really wondering if I should uninstall then reinstall LR then restore the database from a backup.

    I have kept copies of files offsite for years, while I haven't had anything bad happen to my files, I've seen the result of what happens to people that it has. I would rather suffer a bit of inconvenience ;)
     
  4. Fmrvette

    Fmrvette This Space For Rent

    May 26, 2012
    Detroit, Michigan
    Jim
    Interesting.

    Maybe post a question over at The LightRoom Queen's site? If anyone knows the answer outside of Adobe it would be Ms. Bampton.

    The Lightroom Queen Help Desk & Members Area - Powered by Kayako

    Regards,

    Jim
     
    • Like Like x 1
  5. Zariell

    Zariell Mu-43 Top Veteran

    535
    Sep 28, 2012
    Bountiful, UT
    Thanks I might give that a go, that or follow the old code of the west and put a 45 slug into the computer ;)
     
  6. dwig

    dwig Mu-43 Top Veteran

    622
    Jun 26, 2010
    Key West FL
    I'm realitively new user of LR, but have caught it doing a few things I don't care for. I'm sure that if a knew LR better and was more attentive to its foibles I wouldn't have had any issues.

    To resolve my issues, I've adopted a policy of NEVER copying files from my cards or backing up files when LR is running. I don't want to every give it a chance to sniff out the backup and mistake it for working files and I want my own file arrangement that allows a rudimentary logical arrangement that doesn't rely on any one specific software package. My backup drive is never left connected unless I'm doing a backup (as yet, knock wood, I've not needed to do a restore) and LR is never running when the drive is connected.
     
    • Like Like x 1
  7. Zariell

    Zariell Mu-43 Top Veteran

    535
    Sep 28, 2012
    Bountiful, UT
    I have no problems using Lightroom for importing and sorting the files on the PC, backing up I use alt methods, I find with the exception of this glitch it's worked wonders for my workflow time, and even with this glitch no files were moved or harmed, just listed as missing.