Lens Mount

Discussion in 'Olympus Cameras' started by swampduck, Apr 24, 2013.

  1. swampduck

    swampduck Mu-43 Veteran

    335
    Mar 29, 2013
    Taneytown , MD
    Dan
    I bought a lens yesterday and when I went to take off my kit lens it was rather tight. I am not sure what has happened. I looked at the mount and it appears to be fine. This happens with all the lenses I own, so I am quite certain it is the body. Any thoughts?
    Everything works fine, just removing of the lens is not at all smooth.
     
  2. owczi

    owczi nareteV 34-uM

    If it is just not all that smooth i.e. no grinding noise or feel and the lens mount is fine, you should be OK. I have only one lens that does it (14/2.5), so not the body in my case. Is it that you've never noticed this before or do you think it started after that new lens? Did you inspect all surfaces of the mount, and the lens mount?
     
  3. swampduck

    swampduck Mu-43 Veteran

    335
    Mar 29, 2013
    Taneytown , MD
    Dan
    Ok, so i tested things out again...the kit lens is a little tight but nothing to worry about. The 40-150 is nice and smooth. The Panny 14 is really tight, but I am not worried about it since all is working.
     
  4. slothead

    slothead Mu-43 All-Pro

    Aug 14, 2012
    Frederick, MD
    Dan,
    I have found that lenses with metal mounts (e.g., kit lens 12-50) are much tighter (and even sound like they are "scraping"), while the plastic mounts (e.g., the kit lens 14-42) go on and off relatively smoothly. I also notice that your kit lens is a 14-42 which makes me curious about what you have noticed.
     
  5. swampduck

    swampduck Mu-43 Veteran

    335
    Mar 29, 2013
    Taneytown , MD
    Dan
    The Panasonic 14 is really tight when putting on and removing. But it looks like it is something with the lens on Oly bodies. The kit lens is noticeably tighter then the 40-150, but not worrisome.
     
  6. FrayAdjacent

    FrayAdjacent Mu-43 Regular

    183
    Dec 5, 2012
    Austin, TX
    M@
    The kit 12-50 also has an O ring around the outer edge for weather protection. That adds a little friction.
     
  7. Bacek

    Bacek Mu-43 Regular

    64
    Dec 30, 2012
    Lately I had big problem when I have tried to take off P20mm from GF1. It was stacked. I was really worried to not to beak the lens. Had to put lot of pressure. Finally I have succeed. Cleaned the mount, the lens edge and now it's working smoothly.
    I'm not sure how long this lens was on. I suspect more then 2 year. I guess previous owner didn't treat it as EXCHANGEABLE lens camera.

    Regards
    Bacek
     
  8. slothead

    slothead Mu-43 All-Pro

    Aug 14, 2012
    Frederick, MD
    I hadn't noticed the O-ring. Thanks for that info.