1. Reminder: Please use our affiliate links for holiday shopping!

Lens attachment failed. (Help)

Discussion in 'Native Lenses' started by xdayv, Dec 23, 2011.

  1. xdayv

    xdayv Color Blind

    Aug 26, 2011
    Tacloban City, Philippines
    Dave
    just got the 45 1.8 olympus...

    error in mounting both bodies G3 and GF1:

    "Lens attachment failed.
    Please check connection for dirt."
     
  2. SimonL

    SimonL Mu-43 Regular

    97
    Apr 15, 2009
    NW England
    Have you tried looking and comparing the bottom of the new lens with one you know that works ?
     
    • Like Like x 1
  3. Henk

    Henk Mu-43 Regular

    197
    Aug 18, 2010
    the Netherlands
    Be sure that you do not press the lens release button when you mount a lens! Pressing the release button while mounting a lens may result in this message.
     
    • Like Like x 1
  4. xdayv

    xdayv Color Blind

    Aug 26, 2011
    Tacloban City, Philippines
    Dave
    nothing much different. seems ok and clean.
     
  5. xdayv

    xdayv Color Blind

    Aug 26, 2011
    Tacloban City, Philippines
    Dave
    tried again, same thing.

    there's a snap sound, once or twice right after mounting the lens and turning on the power, looks like the lens element movement or something.
     
  6. stratokaster

    stratokaster Mu-43 All-Pro

    Jan 4, 2011
    Kyiv, Ukraine
    Pavel
    Are you sure the lens is mounted correctly? The 45/1.8 is VERY tight, the first time I mounted it on my GH2, the camera displayed the same message.
     
    • Like Like x 1
  7. xdayv

    xdayv Color Blind

    Aug 26, 2011
    Tacloban City, Philippines
    Dave
    yes sir, i think i mounted it correctly. mounted it multiple times to both g3 and gf1... alternately putting also the panny lenses. the panny lenses work every single mount.

    it seems to me there's a misalignment of contacts, communication error of some sort. the aperture only available is f/128.

    and yes the 45 1.8 is tight. i try mounting and unmounting a few times. same result still.
     
  8. stratokaster

    stratokaster Mu-43 All-Pro

    Jan 4, 2011
    Kyiv, Ukraine
    Pavel
    I think your lens is DOA :(
     
  9. xdayv

    xdayv Color Blind

    Aug 26, 2011
    Tacloban City, Philippines
    Dave
    most likely. sending it back. :frown:
     
  10. starlabs

    starlabs Mu-43 Top Veteran

    856
    Sep 30, 2010
    Los Angeles
    Unfortunately, I also think your sample is a dud.

    The first 45/1.8 I ordered had a small segment of what appeared to be some glue resin sandwiched in between the lens! Anyone even taking a somewhat cursory look would've seen this defect. But it shipped anyway. So it's obvious not all lenses are inspected.

    If you ordered directly from Olympus, expect over a month before you can get a new replacement.
     
  11. xdayv

    xdayv Color Blind

    Aug 26, 2011
    Tacloban City, Philippines
    Dave
    tsk tsk... Christmas without the 45 1.8... hhhmmm... i'll weigh in my options.