Is the Olympus M. Zuiko Digital ED 12-40mm f/2.8 PRO Lens Fragile?

Discussion in 'Micro 4/3 News and Rumors' started by Amin Sabet, Dec 27, 2013.

Thread Status:
Not open for further replies.
  1. Amin Sabet

    Amin Sabet Administrator

    Apr 10, 2009
    Boston, MA (USA)
    The Olympus M. Zuiko Digital ED 12-40mm f/2.8 PRO Lens is getting rave reviews from users and professional reviewers alike. However, following a report by one of our members that the mount broke off of his 12-40 with very little impact, three additional owners have posted in our forum to report similar fates for their new 12-40mm lens. In each case, the damage was says to have occurred with little to no impact.

    Such reports aren't unique to this lens. For example, a Google search for "Nikon 24-70 mount broken" turns up a number of similar stories of mounts breaking off with little to no cause. Still, the four reports in our forums of Olympus 12-40 mount breakage, three of which are accompanied by photos, raise the possibility of a manufacturing issue with this new lens.

    I've notified our contacts at Olympus of these reports and will post an update if they provide any additional information. I'm confident that if their investigation confirms that an issue is present, they will take the appropriate steps to address it as they did with the bezel crack issue on the OM-D E-M5 (also first identified and discussed in our forum).

    Here are the posts from users reporting this issue in our forums to date:

    1: https://www.mu-43.com/showthread.php?t=56256&p=560903#post560903

    2: https://www.mu-43.com/showthread.php?t=56256&p=566137#post566137

    3: https://www.mu-43.com/showthread.php?t=56256&p=571220#post571220

    4 (no pics): https://www.mu-43.com/showthread.php?t=56256&p=574029#post574029

    One of the affected members has posted an update to let us know that Olympus is treating his broken lens as a warranty repair: https://www.mu-43.com/showthread.php?t=56256&p=571801#post571801

    For further discussion of this possible issue, please see this discussion thread: https://www.mu-43.com/showthread.php?t=56256

    ----

    Update: I'll continue to add new reports below:

    5 (no pics): https://www.mu-43.com/showthread.php?t=56256&p=574382#post574382

    6: https://www.mu-43.com/showthread.php?t=56256&p=575762#post575762

    ----

    Update: Roger Cicala from LensRentals.com on this posisble issue:

    Read on at http://www.lensrentals.com/blog/2013/12/assumptions-expectations-and-plastic-mounts
     
    • Like Like x 25
Thread Status:
Not open for further replies.