1. Reminder: Please use our affiliate links for holiday shopping!

is my FL600R broken?

Discussion in 'Lighting Forum' started by piggsy, Feb 7, 2015.

  1. piggsy

    piggsy Mu-43 All-Pro

    This worked fine up until a couple of days ago.

    The symptoms are:

    Flash never fires for correct exposure in (M)anual mode or TTL mode. Flash will fire a preflash for exposure adjustment, but will never actually contribute to the scene.

    Flash fires at full power in Auto mode ("A" on the flash). Never does anything else. Always full power, all the time.

    No flash compensation settings, either on the flash unit itself, camera exposure compensation in P mode, the SCP TTL exposure adjustment for the scene, or in the command panel for individual flash groups (enable SCP, "OK", "Info"), have any effect on these results. Always no contribution in M or TTL, always full power in Auto TTL.

    Things that have been tried so far:

    Mounting the flash directly on the hot-shoe of both my E-P5 and E-PM2, and used RC mode.

    A, S, M, P modes on the camera.

    Setting flash exposure compensation to both linked and de-linked from sensor exposure compensation (in utility menu F).

    Using the flash unit's own menus to select between Auto ("A"), TTL Auto, M, different focal lengths, manually setting flash power by GN or by fractions.

    Rotating the flash unit around to face the command flash (LM2 on the E-PM2, onboard popup unit on the E-P5).

    Placing a piece of exposed film over the master flash to make sure that only the command signals, and not the preflashes for control, are contributing to measured exposure.

    Cleaning the sensor glass/pip on the front of the FL-600R.

    Can anyone think of anything else to try? I mean, at this point I'm pretty sure it's buggered, but if there's anything else..
     
  2. inkista

    inkista Mu-43 Veteran

    332
    Jan 13, 2012
    San Diego, CA
    Did you check the batteries, clean the contacts, and check how the flash is seated on the hotshoe?

    It sounds like a miscommunication with the pins not aligning with the hotshoe contacts correctly.
     
  3. piggsy

    piggsy Mu-43 All-Pro

    Batteries are panasonic eneloops (not counterfeit, I hope, bought from digidirect) on about their 5th or 6th charge cycle.

    The hotshoe contacts appear to work - it picks up on changes in distance/power, limits the options properly in iAuto mode, etc, and in any case the problem is identical in RC mode out of either camera's hotshoe too. My guess is that something has screwed up in the sensors either side of the LED on the flash unit and it's unable to properly pick up on how hard it needs to fire - in Auto mode it uses sensor 5, which results in it always firing in full power, in TTL mode it picks up on the command to fire (apparently this is sensor 3 on the left) but does so too weakly, in M mode there's no response to compensation on the flash itself, and no mode has any response to compensation through the camera either on the hotshoe or via RC.
     
  4. klee

    klee Mu-43 Veteran

    367
    Mar 20, 2013
    Houston, TX
    Kevin
    did you check your ISO settings? try aiming the off camera flash directly into the lens or if its on camera, take a selfie in the mirror.

    Did you check the RC menu to see if your flash and camera are assigned to the same flash group and channel? Also, if you mount the flash on camera, disable RC mode, or make sure the on-camera flash is configured properly in the RC menu.

    With RC enabled, you can access the RC menu from the Super Control Panel with the "info" button.
     
  5. klee

    klee Mu-43 Veteran

    367
    Mar 20, 2013
    Houston, TX
    Kevin
    also try configuring your FL600R to slave mode and see if it fires along with your on-camera flash.
     
  6. piggsy

    piggsy Mu-43 All-Pro

    Apparently it was pretty busted. Olympus's repair log -

    Replace main circuit board.
    Replace flash board.
    Replace flash bulb.
    Recalibrate settings.
     
  7. Ross the fiddler

    Ross the fiddler Mu-43 Hall of Famer

    It sounds like you've got a new flash now (well, the guts of it anyhow). :thumbsup: :)
     
  8. piggsy

    piggsy Mu-43 All-Pro

    Yeah it's very tempting to send off the PM-2 to get its occasionally jittery back dial fixed, and see what I get back :D