Hotshoe cover E-M1

Discussion in 'Olympus Cameras' started by gingergirl, Jun 22, 2014.

  1. gingergirl

    gingergirl Mu-43 Regular

    81
    Apr 15, 2014
    I lost the hotshot cover for my E-M1. Should I care? Is it required for weather proofing?
     
  2. OzRay

    OzRay Mu-43 Legend

    Jan 29, 2010
    South Gippsland, Australia
    Ray, not Oz
    It's the first thing I've removed off every one of my cameras. It's not needed at all and provides no weather protection.
     
  3. gingergirl

    gingergirl Mu-43 Regular

    81
    Apr 15, 2014
    Thank you. It's been loose since I've owned the camera so I knew it was only a matter of time.
     
  4. OzRay

    OzRay Mu-43 Legend

    Jan 29, 2010
    South Gippsland, Australia
    Ray, not Oz
    Just keep and eye on the accessory cover though (above the eyepiece), I'm not sure how weatherproof the connector is on that part.
     
  5. gingergirl

    gingergirl Mu-43 Regular

    81
    Apr 15, 2014
    Yes, I suppose that could be an issue.
     
  6. ippikiokami

    ippikiokami Mu-43 Regular

    27
    Mar 19, 2014
    Atlanta, GA
    You can get a replacement piece from the Olympus site if you are worried
     
  7. gingergirl

    gingergirl Mu-43 Regular

    81
    Apr 15, 2014
    I just had another look at my camera and fortunately it is only the hot shoe cover that came off. The accessory port cover is still there andg solidly attached.
     
  8. Tor

    Tor Mu-43 Rookie

    16
    Jun 1, 2014
    Removed it too. No use for it, and in my way.
     
  9. gingergirl

    gingergirl Mu-43 Regular

    81
    Apr 15, 2014
    Thanks everyone. I'll not worry about it since the accessory port is still covered.
     
  10. heinphoto

    heinphoto New to Mu-43

    2
    Mar 1, 2014
    I have lost two of these so far. When I lose the third one (and I'm certain I will), I am giving up. Not the best design, I think.
     
    • Like Like x 1