1. Welcome to Mu-43.com—a friendly Micro 4/3 camera & photography discussion forum!

    If you are thinking of buying a camera or need help with your photos, you will find our forum members full of advice! Click here to join for free!

HLD-6 Grip Buttons

Discussion in 'Accessories' started by mlapinel, May 22, 2012.

  1. mlapinel

    mlapinel Mu-43 Regular

    34
    Mar 14, 2012
    I have the Olympus OMD EM-5 with the grip. I usually use only the landscape part of the grip- but today I added the vertical (portrait) grip. None of the additional dials or buttons (including shutter button) on the portrait grip work. They work fine on the landscape grip. I only have 1 battery. I tried using it the camera and the grip. No difference. Do I need a second battery for the buttons to work, or do I have a defective grip?
    Thanks, MJL
     
  2. Muntjack

    Muntjack Mu-43 Veteran

    208
    Jul 26, 2010
    I presume you haven't locked the button grips with the little lock mechanism?

    M
     
  3. mlapinel

    mlapinel Mu-43 Regular

    34
    Mar 14, 2012
    I did. I thought that mechanism locked the screw to lock the grip on. Thanks. ;) 
     
  4. Muntjack

    Muntjack Mu-43 Veteran

    208
    Jul 26, 2010
    Not immediately obvious is it. Fortunately I read the tiny 'manual' first or I'd have thought the same.

    Glad it's sorted.

    M
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.