Help me, my flash would not fire in my OM-D

Discussion in 'Olympus Cameras' started by silver92b, Mar 2, 2013.

  1. silver92b

    silver92b Mu-43 All-Pro

    Feb 7, 2013
    Atlanta, GA
    Tonight I tried using the little flash unit that came with my camera. I installed it but it simply would not fire! I had just purchased the FL 600 r but did not know how to set it up but in desperation, I mounted it on the camera and got it to fire. I fired in delayed and strange ways but eventually I got it to fire in synch with my shutter and got some pictures that I would not otherwise could have taken. Needles to say, I was in a situation that did not allow me time to study the manual for the camera which is in the computer :(

    Please advise what might be the problem and what I should do to make it work. I did get in the settings and tried different things. Now it might be set all wrong so I would love to hear what settings to use as default for a starting point.

    Thanks in advance!
     
  2. Maxam

    Maxam New to Mu-43

    3
    Mar 2, 2013
    Did you remember to flip the flash head up once you mounted it? It won't fire if it's not flipped upwards.
     
  3. ill_dawg

    ill_dawg Mu-43 Veteran

    201
    Aug 26, 2010
    If you want to make sure it fires, set it to 'fill in'. it sounds like you may have had it set to 'slow2'. To get at the settings, just hit right on the 4-way buttons, that should pull up the flash settings menu. Fill in is the one that just looks like a little lightning bolt. also, as maxam said, make sure you rememer to flip up the flash when you want it to fire.

    hth
     
  4. Lisandra

    Lisandra Mu-43 Veteran

    234
    Nov 16, 2010
    It sounds very silly, but it happened to me for about 15 seconds
     
  5. dagaleaa

    dagaleaa Mu-43 Veteran

    252
    Jun 4, 2011
    Naples, Fl
    Dawn

    It happened to me too! :th_salute:
     
  6. Gary Ramey

    Gary Ramey Mu-43 Veteran

    240
    Dec 27, 2012
    Aurora Colorado
    Sorry but had this idiot fidgeting for longer than I care to admit
     
  7. Maxam

    Maxam New to Mu-43

    3
    Mar 2, 2013
    It most definitely happened to me too, which is why it was the first thing I thought of when I read the post :smile:
     
  8. silver92b

    silver92b Mu-43 All-Pro

    Feb 7, 2013
    Atlanta, GA
    Thanks kind people! I did not even knew it would flip up :doh: Ignorance *is not* bliss.. Anyway, now if fires, but in my state of agitation last night, I made it so when the flash settings come up in the super controller, I can't choose the "Full" option, only the "Fill in", "Off" and "2cn".... I must get back to the menu settings and put the right settings on. Can someone please walk me through this? I'm not lazy and I can read the manual, but I have terminal ADD and it would save me a lot of time and the chance of screwing up the settings even more as I figure it out.....
     
  9. Maxam

    Maxam New to Mu-43

    3
    Mar 2, 2013
    What mode is set on the dial? The flash options differ depending on which mode you're in. Aperture Priority mode gives you the most options, for example, while i-Auto gives you only a couple.

    Oh, and it might be a good idea to reset the camera settings to factory default. Press Menu to go to Shooting Menu 1, then Reset/Myset, then hit Ok on the Reset option. You can also press Right on the Reset option to choose between doing a Basic and Full Reset before you hit Ok on the previous menu.
     
    • Like Like x 1