HELP!! Major problems with my Metz 44

Discussion in 'Accessories' started by jambaj0e, May 5, 2011.

  1. jambaj0e

    jambaj0e Mu-43 Top Veteran

    816
    Aug 31, 2010
    I'm having some major problems with my 2 week old Metz as paired on my month-old E-PL2.

    Up until last week, it was working find, whether it's TTL or wireless TTL. All of a sudden last week, it doesn't always fire properly (sometimes proper exposure, sometimes way overexposed, sometimes way underexposed) even when I wait 5-10 seconds between shots. I changed batteries and everything, too. I tried switching around Auto, Program, Aperture priority, Shutter priority, and Manual. Same thing.


    Then today, I was trying to cycle thru the Manual mode in my to shoot different light strength. All of a sudden, it doesn't fire at all, even in other modes in Wireless TTL or on the hot shoe.

    Finally, I pressed the green lightning button and that made the flash go off again, but with the same exposure problem.

    Furthermore, sometimes, when I turn off the unit, the Power button would blink red for about 5-10 seconds.

    Should I return the unit or is there something wrong in the way I'm using it?
     
  2. SRHEdD

    SRHEdD Mu-43 Top Veteran

    967
    Feb 24, 2011
    Viera, Florida USA
    Steve
    Mine is fine, so I'm grabbing at solutions like you...


    One of the good things about the flash is its USB-update capability. Call their techs and see if you can re-boot it somehow. Maybe Google a file to upload on your own (if you don't care about warranty). It sounds like the tube is working fine, just not the software (?). That'd be my first step.

    http://www.metz.de/index.php?eID=tx...4687788&hash=777ab2ac2c4c0a020eb41a7a62cd3684
     
  3. jambaj0e

    jambaj0e Mu-43 Top Veteran

    816
    Aug 31, 2010
    There is no update on the firmware for the m43 models. Like I said, everything was working fine in TTL and wireless TTL mode until about a week ago.

    Something happened when I tried going on manual mode while going wireless. The shots started to look funny. The flash would go off, but it's as if it flashes at the wrong time and the camera takes the photo right before or right after the flash. I went back to TTL mode in wireless and on the hot shoe and it did the same thing.

    Yesterday was the worst, though. Not only was it doing that even though I put in new batteries and waited 4-5 seconds between shots, at one point, the flash itself wasn't lighting up at all. It wasn't until I pressed the green button with the Lightning that it start shooting again, but w/ the same issues =(
     
  4. SRHEdD

    SRHEdD Mu-43 Top Veteran

    967
    Feb 24, 2011
    Viera, Florida USA
    Steve
    I saw there was no UPDATE, but maybe a Service Tech can send you a reboot via email to reset the flash. The fact that it takes updates tells me they can probably run a diagnostic, and re-install the suitable OEM software/firmware. Certainly worth contacting them to re-install the original code.
     
  5. jambaj0e

    jambaj0e Mu-43 Top Veteran

    816
    Aug 31, 2010


    Link doesn't work :(
     
  6. SRHEdD

    SRHEdD Mu-43 Top Veteran

    967
    Feb 24, 2011
    Viera, Florida USA
    Steve
    I does from my computer here and the office...
     
  7. Jimboh

    Jimboh Mu-43 Regular

    75
    Sep 17, 2010
    Florida
    If two week old and no firmware and no known issues (like shooting under 1/160th), that's what warranties are for. Either return it or get it fixed.
     
  8. jambaj0e

    jambaj0e Mu-43 Top Veteran

    816
    Aug 31, 2010
    I've been shooting between 1/160 to 1/60. I'd get 1 good or over exposure 3-4 underexposed even though the light is green. then another good or over exposure.

    Doesn't matter if it's TTL , wireless TTL, or manual. Even manual flash is inconsistent.


    There's not really any tech support except for Manfrotto distribution in New York. I went to 4 different local camera stores, no one works with Metz =(
     
  9. shoturtle

    shoturtle  

    823
    Oct 15, 2010
    contact manfrotto, they will exchange the unit. They are pretty good with emails and if you call them.

    I had to call them about some warranty issues and they were pretty helpful. If you email metz, they get it over to manfrotto pretty quickly also to get things resolved.

    This is their NJ number. 201-818-9500