1. Reminder: Please use our affiliate links for holiday shopping!

Help - I've killed my new 14-150 Oly zoom

Discussion in 'Native Lenses' started by GCC, Oct 1, 2011.

  1. GCC

    GCC New to Mu-43

    1
    Oct 1, 2011
    Sydney, Australia
    Sorry that this has to be my first post on this great forum.

    I just bought a new EPL 1with the 14 -150 zoom & the VF2 as I'm about to head to South Africa on holiday. Very excited as I've used a Pen EP 1 + 17mm for a couple of years now.

    Anyhow, loaded IB, loaded Oly firmware updater, updated camera firmware, then...
    I was distracted while the firmware updater was doing the lens update and clicked "next" before the the camera LCD said "OK". Then both the PC software and the camera seemed to be "stuck" with nothing happening for several minutes - so I unplugged the camera.
    Now the lens doesn't work at all and isn't recognised by the updater or by the camera body.
    Has anyone here made the same fatal error and recovered, or knows of a way to "fresh install"firmware to a lens?
    The worst thing is that I have 2 working days until the plane leaves so no time to take this to an Oly service centre.
     
  2. Canonista

    Canonista Mu-43 Top Veteran

    563
    Sep 3, 2011
    L.A.
    Olympus firmware updater website: "Do not turn off the camera or disconnect the cable while the software is starting or running, as it may cause the camera or software to malfunction." Doesn't sound good. :frown:
     
  3. lannes

    lannes Mu-43 Regular

    49
    Jul 15, 2011
    Perth, Australia
    I think Olympus will be the only one who could "reflash" the firmware on the lens
     
  4. turtleboy133

    turtleboy133 Mu-43 Rookie

    21
    Oct 13, 2011
    I just did the same thing to my 14-150mm. I agree, the message on the computer is *very* misleading. It said to disconnect the cable, so I did under the assumption that it needed to do so to complete the update.

    You have to send it back to Olympus for repair. Fill out the form on their website.
     
  5. hkpzee

    hkpzee Mu-43 All-Pro

    Sep 5, 2011
    Hong Kong
    Patrick
    Did you buy the lens brand new at a store, or did you order online? If you bought at a store, your best solution is bring your lens back to the store, explain to them your situation, and hope that they will replace a new one for you so that you don't have to bring it to a service center...
     
  6. RobWatson

    RobWatson Mu-43 Hall of Famer

    Or don't explain and tell them it don't work and hope for a swap!
     
    • Like Like x 1