Has Olympus fixed the shutter issue on OM-D Mk II?

Discussion in 'Olympus Cameras' started by number17, Jun 18, 2017.

  1. number17

    number17 Mu-43 Regular

    28
    Jan 19, 2011
    Hi all,

    I was a happy owner of OM-D E-M5 Mk1 ... until one day out of the blue its shutter was stuck closed, I browsed this forum and got a lot of help. Seems like it's not an uncommon issue with the Mk 1 E-M5, despite trying all the advices here I couldn't get it unstuck for good. So my beloved E-M5 bites the dust, and I went back to my E-PL1 for a while.

    Now that I am planning another vacation I want to get an OM-D camera again, and I'm looking at the E-M10 Mk II. It has all the features I want, and I can re-use all my lenses too.

    I just want to make sure Olympus has fixed the shutter issue on the Mk II OM-D's? Last thing I want is to buy another O-MD and then find out it's got the same issue.

    Has anyone run into these shutter issues (or any issue) with MkII O-MD's, especially the E-M10's?

    Thanks!
    Derek
     
  2. Phocal

    Phocal Mu-43 Hall of Famer

    Jan 3, 2014
    I'm not aware of any shutter problems with any of OMD cameras.
     
    • Agree Agree x 2
  3. retiredfromlife

    retiredfromlife Mu-43 All-Pro

    May 15, 2016
    Sydney, Australia
    • Agree Agree x 2
  4. Christop82

    Christop82 Mu-43 Top Veteran

    504
    Sep 10, 2016
    The epl1 and epm1 had issues, any other model with that issue is most likely a fluke. I wouldn't hesitate to buy a 10ii or a 5ii.
     
  5. number17

    number17 Mu-43 Regular

    28
    Jan 19, 2011
    I had issue with OM-D E-M5 Mk1 with shutter stuck closed ... then when I did a search on this forum (and others) seems like they are quite common.

    But glad to hear Mk2 seems to be fine.
     
  6. AussiePhil

    AussiePhil Mu-43 All-Pro

    Jun 1, 2014
    Canberra, ACT, Aust
    Phil
    Considering there are now THREE mk2 OMD cameras any chance the thread title can be changed ? Pretty please?
     
    • Funny Funny x 2
    • Like Like x 1
  7. Hypilein

    Hypilein Mu-43 Top Veteran

    916
    Mar 18, 2015
    I've had a stuck shutter on my GX7 and had it fixed under warranty. I think it's probably a problem that can happen with all manufacturers but is a rare occurrence. I don't think the OMDs are particularly affected.
     
    • Agree Agree x 1
  8. piggsy

    piggsy Mu-43 All-Pro

    This seems to be a known issue from before -

    OM-D M5 Shutter problem

    I've also just had my E-P5 taken out of action totally by what seems like the same issue - the shutter sticking after 1 exposure - so, you know, keep on being garbage olympus.
     
  9. Phocal

    Phocal Mu-43 Hall of Famer

    Jan 3, 2014
    A couple of people saying they had a shutter problem doesn't = known shutter problem.
     
    • Agree Agree x 2
  10. DocZZZ

    DocZZZ Mu-43 Regular

    52
    Mar 20, 2017
    Refurbished em10ii's are $299 or something like that off of Olympus outlet USA. I would say this is a pretty good sign we'll be seeing an em10iii sooner rather than later. If you don't want to wait (and pay much more) for that one I'd pick up the EM10ii refurbished. That's an amazing price.
     
  11. SkiHound

    SkiHound Mu-43 Veteran

    365
    Jan 28, 2012
    The shutter failed on my E-M5 original version too. I recall reading that it wasn't that uncommon. I've not had, nor have I read about, any issues with the shutter on the E-M10ii. Doesn't mean an individual camera couldn't fail but I've not seen any reports of systematic issues.
     
  12. wolfie

    wolfie Mu-43 Top Veteran

    861
    Apr 15, 2009
    Auckland, New Zealand
    I'd say Olympus has had less numerous problems than most. Never heard of a common shutter issue. But contrast that with Nikon's recent major gaffs over the years, like the infamous oil smeared sensors on the D600 and the D800 series model with faulty AF sensors ...
     
  13. number17

    number17 Mu-43 Regular

    28
    Jan 19, 2011
    THanks guys ... good to hear the shutter problem has not re-surfaced on the EM10II ... I'll just wait for a sale and go for it (Olympus Canada doesn't have an outlet or refurbished units for sale ... though Henry's have from time to times. Still, with EM10II going for CDN$569 on sale, I'd rather wait for sale on a new one)

    I wouldn't say the shutter problem on EM5 happened to 'just a couple cameras' .... a quick search on this forum, or google, or even YouTube shows it's more common that that. I agree these problems can happen to any camera manufacturer and Nikon could have had it even worse, so let's call a spade a spade.