1. Reminder: Please use our affiliate links for holiday shopping!

GX7 Panorama Issue

Discussion in 'Panasonic Cameras' started by oldracer, Jan 13, 2014.

  1. oldracer

    oldracer Mu-43 All-Pro

    Oct 1, 2010
    USA
    I am seeing a (firmware?) problem with the GX7 pano mode:

    When panning from left to right, the left edge of the first frame is the left edge of the pano. The right edge of the pano, though, is not the right edge of the last frame. It is approximately the middle of the last frame. This means that I have to pan approximately 1/2 frame past what I want to be at the right edge of the pano or it will be cropped off..

    Said another way, the pano stitching firmware uses 100% of the leftmost frame but only the leftmost 50% of the rightmost frame.

    When panning right to left, the effect is reversed. The rightmost frame is used 100% and only half of the leftmost frame is used.

    Has anyone else seen this? Those with GX7s can you test and see whether this is true with your camera as well? It's hard for me to believe that this issue is unique to my particular camera.

    TIA.
     
  2. Ultbruin

    Ultbruin Mu-43 Rookie

    12
    Oct 30, 2013
    I can confirm this is true as well. I had to redo several pano because I thought I had reach my goal edge on the right but it didn't.
     
  3. Duncan

    Duncan Mu-43 Regular

    110
    Oct 31, 2013
    Just tried it with my GX7, and I got the same result. I hadn't noticed this before because I've only tried the pano a couple of times, so this is good to know. Thanks.
     
  4. _Matthias_

    _Matthias_ Mu-43 Rookie

    12
    Jan 4, 2014
    Stuttgart, Germany
    Matthias
    That's what the manual says, they even have a graphics in there that shows that about half of the last screen will not be part of the picture
     
  5. T N Args

    T N Args Agent Photocateur

    Dec 3, 2013
    Adelaide, Australia
    call me Arg
    Read the you-know-what ;)

    It is clearly explained in the manual. Follow the manual and you will be fine.
     
  6. oldracer

    oldracer Mu-43 All-Pro

    Oct 1, 2010
    USA
    Got it! It's not a bug, it's a feature. The last refuge of incompetent programmers.
     
  7. T N Args

    T N Args Agent Photocateur

    Dec 3, 2013
    Adelaide, Australia
    call me Arg
    Whatever.
     
  8. bwana

    bwana New to Mu-43

    7
    Apr 19, 2012
    The pano function is poor. I have found significant vertical banding when there is a broad dynamic range across the image. Thick vertical bars of exposure variation . The HDR function needs work too. Image alignment is poor resulting in significant ghosting. The iPhone never has these problems.