GX7 & high speed sync

Discussion in 'Panasonic Cameras' started by OYC, Aug 19, 2015.

  1. OYC

    OYC New to Mu-43

    1
    Aug 19, 2015
    Hey everyone

    My name's OYC I'm a music teacher out of Lyon, France. I guess that's as good an intro as any...

    For the past few days I've been (litterally, sometimes) banging my head trying to get HSS with my GX7 and a Yongnuo 568ex II. It works ok with my Canon 650d, since the Yongnuo things I bought are built for Canon, but I was really looking forward to using this with the portability factor of the GX7 and its 1/8000 (vs 1/4000 on the 650d.)

    Here's what I have :

    1 x YN622C-TX transmitter
    2 x YN 622C transceivers
    1 x YN568ex II flash
    1 x GX7 w/ a 20mm 1.7 II

    Could anyone here PLEASE help me figure this thing out ? I've tried almost everything... And I'm stuck at 1/500 with the GX7 at HSS (though I don't know if it's HSS...) above that I just get a black screen. I think I can't get it to sync properly because it works really fine at 320, somewhat okay-ish at 500 and I get nothing beyond that. Thing is, when I mount the YN622C-TX on the GX7, it disables the wireless FP menu. It all becomes greyed out and all I get is the first page of the menu with TTL and forced flash.

    I swear I could send a thank you card, a real one, to anyone who helps me figure this out.

    Thanks,
    OYC
     
  2. neelsd

    neelsd Mu-43 Veteran

    258
    Nov 17, 2011
    Roseville, CA, US
    In my experience, you can't get HSS to work using a Panasonic camera with a non-Panasonic HSS trigger. Compare the pins of the YN622C-TX transmitter with the pins on the camera hotshoe....do they line up? If not, HSS will not work with that trigger.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.