GX7 and Yongnuo RF-603C Triggers

Discussion in 'Panasonic Cameras' started by ranxoren, Sep 28, 2013.

  1. ranxoren

    ranxoren Mu-43 Top Veteran

    631
    Apr 22, 2013
    Toronto, ON
    OT
    So I wanted to do a off camera flash shoot yesterday.
    Grabbed the GX7 along with my Yongnuo RF-603C Triggers and unfortunately nothing...
    These worked with my Fuji Cameras as well as my Ricoh GR but I cannot seem to get them to work on the GX7.
    Has anyone here gotten them to work on a Panasonic body before?

    Thanks!
     
  2. alex66

    alex66 Mu-43 Top Veteran

    715
    Jul 23, 2010
    Not sure if they are the same but I have the RF-602TX ones and they transmited perfectly well on a G3.
     
  3. ranxoren

    ranxoren Mu-43 Top Veteran

    631
    Apr 22, 2013
    Toronto, ON
    OT
    So Ill use this Google Image as a way to describe my issue:

    YN-RF%252520603C%252520-%2525203344.

    See how both triggers have green lights on their left and right?
    With the GX7 I can only get both lights to turn on on the trigger attached to the body when the two back connectors are hanging outside the hotshoe while the front ones are touching the contacts.
    When the trigger is fully installed on the hotshoe one of the lights turns off :(
     
  4. ThomD

    ThomD Mu-43 Veteran

    426
    Jun 1, 2013
    SF Bay Area
    Not compatible with some (all?) Panasonics out of the box. Google for a way to hack it to make it work.
     
  5. ranxoren

    ranxoren Mu-43 Top Veteran

    631
    Apr 22, 2013
    Toronto, ON
    OT
    Hey thanks for the tip - any more details by any chance?
     
  6. alex66

    alex66 Mu-43 Top Veteran

    715
    Jul 23, 2010
    Could it be that the rear pins are creating some form of short?
     
  7. ranxoren

    ranxoren Mu-43 Top Veteran

    631
    Apr 22, 2013
    Toronto, ON
    OT
    That's what it looks like.
    I searched for DYI methods as per ThomD's advice and I found this thread:

    http://www.dpreview.com/forums/thread/3076574

    Seem to be having a similar issue I'm having with a G3.
    I'll try that and report back here for any other GX7/RF-603C users.

    Edit: doesn't look like Ill be able to try that anytime soon as it requires a soldering iron.
     
  8. ThomD

    ThomD Mu-43 Veteran

    426
    Jun 1, 2013
    SF Bay Area

    Sorry, I haven't done it. It is just something I turned up when I was looking for triggers. I see you've found the reference thread on a fix.