GX1 Flash Not Firing

Discussion in 'Panasonic Cameras' started by xlerate, Dec 26, 2012.

  1. xlerate

    xlerate New to Mu-43

    Mar 12, 2012
    New York
    I search the term 'flash' for all 13 resulting pages before posting and did not find an answer.

    Short version: the on camera flash has all of a sudden stopped working. It is in the popped-up position, and the result is the same under any shooting mode (P,A,M). On each mode with the flash popped-up, the icon appears on the lcd screen indicating flash is disabled (circle with line through it). I've gone through the menu into the flash settings and toggled the available setting with no luck.

    Any ideas what may be causing this?
    Does it have to go in for service?

    Attached Files:

  2. 00r101

    00r101 Mu-43 Regular

    Jan 21, 2012
    If it shows a line through the flash then you have disabled it.
    Slow down and find the right menu choice and enable it (it could be you have it disabled on the quick menu. On the main menu try setting forced flash ON. It is possible if you have it in auto mode and you are shooting in good light that the cam feels you do not need flash. Forced flash on overrides that.
  3. xlerate

    xlerate New to Mu-43

    Mar 12, 2012
    New York
    Thank you for the reply 00r101

    I have been through all of the menu options and do not see, (nor do I think there is a way) to disable to flash.
    I only see the option to force on, which it is but I do not see any way of disabling.
    Am I missing something?
  4. obie131

    obie131 Mu-43 Rookie

    Mar 7, 2012
    In P,A,M, it all reverts to your setting (which is flash off, regardless if the flash is in the up position). Try it in full automatic. If the flash works then, then you have it turned off. I don't have your camera so I don't know the dial layouts, but it usually found from one of the four way buttons for flash control.
  5. xlerate

    xlerate New to Mu-43

    Mar 12, 2012
    New York
    Thank you for the reply obie131.

    With my camera in Auto mode (P on the GX1) and the menu set to 'flash force on' and there is no physical button on the camera 4-way dial that controls flash. The flash remains disabled.

    Attached Files:

  6. elavon

    elavon Mu-43 All-Pro

    Sep 1, 2012
    Tel Aviv Israel
    Real Name:
    Set the camera to IAuto.
    It is the the red button on top of the camera and try to shot in very low light with flash open.
    If it fires then you have a configuration option in PASM.

    I set my camera to flash force when the flash is open. in this case if I want flash I just open it.
  7. beehole1

    beehole1 Mu-43 Regular

    Mar 7, 2011
    I have the G5,if I activate the electronic shutter the flash does not work,does the GX1 have electronic shutter?
  8. Henk

    Henk Mu-43 Regular

    Aug 18, 2010
    the Netherlands
    No, G5 was the first model featuring an electronic shutter. GH-3 has one too.