Greenish tint to the OM-D screen?

Discussion in 'Olympus Cameras' started by hazwing, Dec 20, 2012.

  1. hazwing

    hazwing Mu-43 All-Pro

    Nov 25, 2012
    Australia
    I'm noticing a green tint to the back screen on my om-d. I've tried adjusting the colour temperature in the settings, but this only seems to change blue/yellow range. Probably needs a bit of red/magenta to balance out the green. Is this normal?
     
  2. Chronos

    Chronos Mu-43 Regular

    129
    Oct 18, 2012
    Colorado
    Chris
    Mine has a greenish tint when shooting indoors at my house, i think it is something about my wall color messing up the white balance, it does not seem to do it all the time.
     
  3. DPitts

    DPitts Mu-43 Rookie

    15
    Dec 15, 2012
    Raleigh NC
    Doug Pitts
    mine is perfect.
     
  4. hazwing

    hazwing Mu-43 All-Pro

    Nov 25, 2012
    Australia
    I must have gotten back luck of the draw with my camera LCD. Definitely a slight greenish tint to the LCD. definitely gonna annoy when i'm reviewing my photos on the LCD
     
  5. Mikefellh

    Mikefellh Mu-43 Top Veteran

    939
    Jun 7, 2012
    Toronto, Canada
    Are you saying the white menu text is green, or just the pictures are green instead of white?

    If you mean that black on the monitor has a greenish hue when the lenscap, both of my E-M5s exhibit this effect.

    Have you tried to do a full reset, Menu, camera 1, Reset/MySet, Reset, select Full, then OK.
     
  6. hazwing

    hazwing Mu-43 All-Pro

    Nov 25, 2012
    Australia
    The pictures are still in colour but there is a slight greenish hue to them.
     
  7. ice_man

    ice_man Mu-43 Regular

    158
    Dec 19, 2012
    Socal
    Z
    I have this on problem on my LCD as well. There's a greenish hue to the lcd and evf. But i checked the files on my computer and it was okay.


    Tapatalk.
     
  8. duke

    duke Mu-43 Veteran

    420
    Dec 4, 2010
    Tulsa, moving to Houston
    Duke
    I don't know if the one I have now does this but I remember a previous one had a green tint when viewed from the side, but not when viewed dead on.
     
  9. M4/3

    M4/3 Mu-43 Top Veteran

    713
    Sep 24, 2011
    I got used to the green tint of the LCD and then learned to ignore it so it's now a non-issue for me. There is no green tint to the actual photos the camera takes.
     
  10. ice_man

    ice_man Mu-43 Regular

    158
    Dec 19, 2012
    Socal
    Z
    Yeah. The green tint is only in the LCD and EVF.

    It's just a bit hard to tell if I got the correct color. I think maybe because the OMD has an OLED screen.


    Tapatalk.
     
  11. hazwing

    hazwing Mu-43 All-Pro

    Nov 25, 2012
    Australia
    +1

    it doesn't affect the final image but when reviewing it and showing the photos to other's on the camera, the green is not flattering.

    its nice to know at least I'm not the only one with the issue.
     
  12. ice_man

    ice_man Mu-43 Regular

    158
    Dec 19, 2012
    Socal
    Z
    yeah. wish they'd just stuck to LCD instead of OLED.

    But it's all good I guess.
     
  13. rijesh

    rijesh Mu-43 Regular

    43
    Nov 11, 2011
    I only experience a green tint when looking off angle.