Got OMD back from Olympus. What a disaster! Problem solved!

Discussion in 'Olympus Cameras' started by Ig7, Oct 3, 2012.

  1. Ig7

    Ig7 Mu-43 Veteran

    306
    Aug 24, 2011
    Just got my OMD back from Olympus after having the sensor cleaned. Turned the camera on and all I can see on my screen is the SCP. I can only see the image in the EVF. Besides, all my settings were erased. Unfortunately too late to call Olympus, but I wonder if it happened to anyone else?
     
    • Like Like x 1
  2. Bhupinder2002

    Bhupinder2002 Mu-43 Hall of Famer

    Hi
    There is a small button on side of EVF, if u press that it will show ur normal LCd
    Cheers
    Bhupinder
     
    • Like Like x 5
  3. Ig7

    Ig7 Mu-43 Veteran

    306
    Aug 24, 2011
    OMG!! I feel soo stupid! Thanks a million!
     
  4. littleMT

    littleMT Mu-43 All-Pro

    Apr 8, 2012
    Lucille Sanchez
    this shows the value of this forum... thanks Bhupinder2002
     
    • Like Like x 1
  5. Ig7

    Ig7 Mu-43 Veteran

    306
    Aug 24, 2011
    Just got of the phone telling my friend exact same thing!
     
  6. newbert

    newbert Mu-43 Veteran

    292
    Jul 22, 2012
    Glens Falls, NY
    If you don't mind, what did Olympus charge you for the sensor cleaning? And how long did it take to get your camera back?

    Thanks.
     
  7. Ig7

    Ig7 Mu-43 Veteran

    306
    Aug 24, 2011
    I sent the camera to Olympus because I tried cleaning the sensor using "wet method" which is not allowed because of the sensor suspended in the magnetic field, which is not mentioned anywhere in the manual. They cleaned it under warranty and the turnaround was only a few days. No complaints.
     
    • Like Like x 1
  8. dhazeghi

    dhazeghi Mu-43 Hall of Famer

    Aug 6, 2010
    San Jose, CA
    Dara
    Wow, that's helpful of them. I'll have to remember to send my camera in for cleaning right before the warranty expires...
     
  9. Ig7

    Ig7 Mu-43 Veteran

    306
    Aug 24, 2011
    I think the issue here is that because of the sensor being suspended, you cannot clean it using the traditional methods like other cameras. This is also not known unless you start digging for info. I read a quote from Olympus on DP review forum that this type of sensor should only be cleaned by Olympus, which was confirmed by customer service when I called them. According to their tech support, the IS and alignment will be messed up if not cleaned by Olympus. I was also originally quoted $300 fee but Olympus did clean it under warranty.
     
  10. RT_Panther

    RT_Panther Mu-43 Legend

    May 4, 2011
    Texas
    Is this only applicable to the 5-axis OMD or all models :confused:
     
  11. Ig7

    Ig7 Mu-43 Veteran

    306
    Aug 24, 2011
    I believe it is only applicable to the 5-axis OMD
     
  12. gunky

    gunky Mu-43 Rookie

    12
    Oct 2, 2012
    You can clean the sensor by 2 ways..

    Air pumping or with rice paper and cleaning liquiq..

    Note:

    The best way to check if you ccd, lenses are dirty just put f to 22 focus in a white area midle range wait to focus. Change focal distance to close but a surface still bright.

    If there's dirty it will appear. The cleaning on warranty it's free. If theres dirty between the glass filter and ccd the whole kit will be change....