Got my EM1 repaired

Discussion in 'Olympus Cameras' started by ashburtononline, Apr 5, 2016.

  1. ashburtononline

    ashburtononline Mu-43 Veteran

    Jan 21, 2015
    New Zealand
    Sent it in to our NZ agent on Friday for a new viewfinder LCD (green blobs). Got it back on Tuesday by courier. Fantastic service !
  2. gnarlydog australia

    gnarlydog australia Mu-43 Top Veteran

    Feb 23, 2015
    Brisbane, Australia
    Real Name:
    Damiano Visocnik
    wow, that is stupid fast! if I need service on my Olympus camera I might send them across the pond to NZ instead of OZ; It took more than 3 weeks to get my E-P5 wheels fixed (warranty)
  3. Ross the fiddler

    Ross the fiddler Mu-43 Hall of Famer

    May 20, 2012
    Blue Mountains, NSW, Australia
    Real Name:
    Typically Sydney (Macquarie Park) is normally one week turnaround. I would think the longer time was due to lack of replacement stock for that item, but that NZ return was very fast.
  4. aukirk

    aukirk Mu-43 Regular

    Sep 9, 2012
    I need to send in my EM-1 due to occasionally missing clicks with the rear dial... but hate to be without it for any long period of time as my son's baseball season is underway. However, this is encouraging... maybe I will fill out the form and bite the bullet before summer is upon us.
  5. ashburtononline

    ashburtononline Mu-43 Veteran

    Jan 21, 2015
    New Zealand
    and ..... I just sent it back .... green blobs re occurred .... Tech said it was the 13th he has repaired and he has done 3 for me .... I'm either unlucky or cursed. Anyhow, he has the parts and said he would fix it immediately. He will get it on Wednesday so I should get it Friday :) ??
  6. Koru

    Koru Mu-43 Regular

    Nov 23, 2014
    Auckland, New Zealand
    Terrible bad luck for you. Was it done under warranty?
    I have had 2 sensors replaced on mine, luckily on extended warranty. Don't know what happens when the present one blows out!