GM5 full spectrum concersion

laptoprob

Mu-43 Regular
Joined
Jan 28, 2010
Messages
72
I finally received the correct sized clear glass to replace the blue filter in the GM5. Hot mirror is removed and the camera works fine. BUT. There's a flashing light, originating from inside the camera. It doesn't look digital, but I can't figure out where stray light might get to the sensor. And where it comes from.
Intensity varies with shutter speed of course, the flashing looks regular. Can't share a short video here sadly.
Who knows about this problem?
I also have a IR converted GF6, which is built differently. This doesn't show this problem. And tried to convert a GF7, which is very similar to the GM5, but that one died in surgery due to fragile ribbon contacts.
 

Attachments

  • 1060909.jpg
    1060909.jpg
    270.9 KB · Views: 27
  • 1060910.jpg
    1060910.jpg
    378.6 KB · Views: 28

kbouk

Mu-43 Regular
Joined
Dec 21, 2013
Messages
119
Location
Greece
it’s a well known problem with some Panasonic bodies which use an infrared shutter diagnostic LED on its mechanical shutter.

List of Panasonic cameras with shutter LEDs in the description on the Kolari site:

https://kolarivision.com/product/panasonic-micro-four-thirds-infrared-conversion/

Micro Four-Thirds: G1, G10, G2, G3, G5, G6, G7, G9, GH1, GH2, GH3*, GH4*, GH5*, GH5s, GF1, GF2, GF3, GF5, GF6, GX1, GX7*, GX8*, GX85*, GX9*, G90, G95, GM1*, Fz2000

*These cameras have an internal IR shutter diagnostic LED that can cloud the images in some shooting settings. Can be worked around in most cases by using the camera in silent mode.
 

laptoprob

Mu-43 Regular
Joined
Jan 28, 2010
Messages
72
Thanks a lot! That looks like the cause. Sadly using the E shutter doesn't solve the problem...
 

laptoprob

Mu-43 Regular
Joined
Jan 28, 2010
Messages
72
With this knowledge I can at leaast find the troubling LED and shield it with a thin piece of neoprene. Mechanical shutter is obviously completely blocked, but the E-shutter works fine. To my surprise this 2mm strip on the side doesn't show up at all. So the sensor is quite a bit bigger than the effectively used part.

Thanks again!
 

Attachments

  • P1010216.JPG
    P1010216.JPG
    341 KB · Views: 25

ibd

Mu-43 Top Veteran
Joined
Jun 5, 2016
Messages
581
Great, I love crafty GM5 hacks!
 

Latest threads

Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Mu-43 is a fan site and not associated with Olympus, Panasonic, or other manufacturers mentioned on this site.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Forum GIFs powered by GIPHY: https://giphy.com/
Copyright © Amin Forums, LLC
Top Bottom