GM1 users: loose/unfirm display?

Discussion in 'Panasonic Cameras' started by DingDong, Apr 11, 2014.

  1. DingDong

    DingDong New to Mu-43

    Apr 11, 2014
    Hi there GM1 users,

    I recently bought a GM1 and now noticed that the display sits a bit unfirm in the body. When I press on the lower edge it goes in for approx. 1mm. You also hear it (creaky sound :)). This doesn't match the excellent built quality of the rest of the body, so i find it a bit annoying. Does anyone of you experience the same? You think this flaw enables for a repair (warranty)?

    Thanks for your answers
  2. Benzy

    Benzy Mu-43 Regular

    Mar 18, 2014
    Cant speak to the GM1 specifically but my GF6 is as you describe sans the creak.

    On the other hand, my Gx7 display sits so tightly that I'd never guess it tilted unless I was told.
  3. DingDong

    DingDong New to Mu-43

    Apr 11, 2014
    The GM1 doesnt have a tilting screen :) The problem here is that the display sits loose in the body. I was wondering if this is due to the general built quality of the GM1 or if I had bad luck with my model...
  4. Glenn S

    Glenn S Mu-43 Top Veteran

    Feb 1, 2010
    My GM1 screen is solidly attached, U suspect yours is faulty and should be returned.
  5. SojiOkita

    SojiOkita Mu-43 Top Veteran

    Feb 23, 2014
    No problem on mine either.
  6. DingDong

    DingDong New to Mu-43

    Apr 11, 2014
    ok, thanks guys! i think i'll return it.
  7. Indianpeaksjoe

    Indianpeaksjoe Mu-43 Top Veteran

    Oct 1, 2012
    One more data point. My GM1 has no issues.