1. Reminder: Please user our affiliate links to get to your favorite stores for holiday shopping!

GH3 won't accept firmware update

Discussion in 'Panasonic Cameras' started by londonfire, Aug 12, 2015.

  1. londonfire

    londonfire Mu-43 Regular

    74
    Mar 18, 2014
    Western NC
    Hi, guys. I wanted to update my GH3 to 1.2 before leaving and I have an issue that I haven't read about in this forum. I have downloaded the file, extracted it and now have the .bin file. Transferred it to the SD card, put it in the camera trying 3 fully charged batteries and when I go to the playback menu all I get is the pic I took and no update screen. I've tried it with no pics on the card and gotten the 'no valid picture to play' message and I've also tried it with the camera coupled to USB. With this method I get the 'Access' icon on the screen but when I try to go to playback the only thing that happens is that the battery icon comes on. Normally, I would think that this action is telling me the battery isn't fully charged but as mentioned I tried 3 different batts right off the charger. I know I must be missing something. I've done many G cameras before without a hitch.
     
  2. Bif

    Bif Mu-43 Veteran

    379
    May 28, 2012
    San Angelo TX
    Bruce Foreman
    Are you formatting the SDHC card IN CAMERA before copying the .bin file to the card?

    Some say you should also take about 2 quick stills after inserting the IN CAMERA formatted card with .bin file copied to it. I don't think I ever did that. But there should be no other .exe files on the card as that will cause an error.

    I would also try a different card just in case.

    Format card in camera.

    Remove card from camera and insert into PC reader, copy .bin file over to card.

    Remove card from PC reader slot and put back in camera.

    Power up camera and press PLAY.

    Should work from there.
     
    • Agree Agree x 1
  3. Wasabi Bob

    Wasabi Bob Mu-43 Top Veteran

    Follow these steps:
    1. Double check to see if you possibly already updated it!
    2. Format an SD an card in the camera and take one or two photos. The photos will prevent the "no valid photos" error message from being displayed.
    3. Download the file again, just in case you corrupted it somehow. Extract the file to your desktop or other location of your choice.
    4. COPY and PASTE (do not drag and drop) the bin file to the root of the SD card.
    5. Make sure you have a fully charged battery in the camera.
    6. Turn the camera ON and place it in PLAY mode. It should automatically load.

    STEP #4 is especially important if you are using a MAC. In every case where firmware would not load, #4 did the trick.