1. Reminder: Please use our affiliate links for holiday shopping!

GH3 back button (ae/af) focus issue

Discussion in 'Panasonic Cameras' started by ripleys baby, Mar 10, 2015.

  1. ripleys baby

    ripleys baby Straw clutcher

    608
    Aug 10, 2011
    Hi GH3 users, Please could someone confirm if this is normal on the GH3

    The camera is switched on.

    After about ten seconds of inactivity the focus box disappears .

    Then if you press the shutter button all the way through, it focuses and takes a picture.

    Great.

    Now , with the shutter button af set to off and the ae/af button set to af on.

    after about ten seconds the af box disappears. But this time i have to press the the ae/af button twice.

    once to re display the af box and again to get focus lock (in single and continuous)

    I like the camera set up with back button af , but this issue really annoys. Am i missing something ?

    thanks
     
  2. Bif

    Bif Mu-43 Veteran

    380
    May 28, 2012
    San Angelo TX
    Bruce Foreman
    The first press of the AE/AF button does one SAF operation then shifts to MF and the camera remains in MF until you power down, shift mode, or...Press the AE/AF button again which clears the back button AF mode and defaults back to shutter half press AF.

    I have mine (and my GX7 & GH4 also) set for back button AF. If you haven't already, go into the menus and set MF ASSIST to ON and select the focus ring to be the control.

    Gives you the best of both AF and MF. One press of the AE/AF button does the AF and if that's good I take the shot. Next shot I touch the focus ring on the lens and the magnified assist kicks in so I can "nail" focus quickly. One light touch of the shutter button clears the magnification and a full press takes the picture. Anytime I need autofocus again another press of the AE/AF button clears the MF and I can either press that button again or use the shutter button.

    I like it.
     
    • Informative Informative x 1
  3. ripleys baby

    ripleys baby Straw clutcher

    608
    Aug 10, 2011
    Thank you for the reply but it doesn't address the issue I have.
     
  4. Bif

    Bif Mu-43 Veteran

    380
    May 28, 2012
    San Angelo TX
    Bruce Foreman
    Yes it does. The reply explains what is happening. The disappearing green focus box, along with any info on the screen, is normal behavior for the GH3 (and GH4). That is designed into the display function to prevent "burn in".

    You can "bring it back" with a light touch on the LCD (if you have touchscreen enabled), a half press of the shutter button, pressing one of the function buttons, or switching LCD to EVF (or EVF to LCD) using the eye sensor. Pressing the AE/AF button to "bring it back" also "clears" the "back button" function back to default half press of the shutter button for AF which is why you have to press it again to get another "back button" focus lock. Just remember it also switches over to MF immediately after achieving AF focus lock in this mode.

    So instead of pressing the back button again (and then again once more) try turning the focus ring on the lens (you have to have MF + ASSIST configured for the magnified assist to "kick in").

    I just pulled one of my GH3s out of the safe and confirmed all of the above.

    A lot of folks really complained about the "disappearing" onscreen data and aids but Panasonic didn't change it on the GH4. Still the same.
     
    • Like Like x 1
  5. ripleys baby

    ripleys baby Straw clutcher

    608
    Aug 10, 2011
    Again thank you for the reply . I have resolved the problem by enabling the eye focus. (That I'm not really keen on)
    Without this the issue remains
    In shutter button af.
    I don't need to press the shutter button once to display box then press again to acquire focus.
    In back button focus mode I would prefer one press to re display the box and focus in one press.
    Even though I'm not keen on eye focus . It works . I don't want to be fiddling around with manual focus either .
    "Burn in" ? I don't get that one. If that was the case why doesn't the level display go out too ( if it's enabled) ?
     
  6. PeeBee

    PeeBee Mu-43 Top Veteran

    657
    Sep 17, 2012
    UK
    Do you have an option for 'AF/AE Lock Hold'? On my G5, this option sets the AF/AE Lock button to either a one press (press to activate) or 2 press (toggle on/off) operation. You'd need to set this option to off for a one press operation.
     
  7. ripleys baby

    ripleys baby Straw clutcher

    608
    Aug 10, 2011
    Yes I do have these options on the GH3.
    However this problem is while the setting for the ae/af is on - af on.
     
  8. PeeBee

    PeeBee Mu-43 Top Veteran

    657
    Sep 17, 2012
    UK
    Yes, I've just tried on the G5 and it does the same thing. After a preset amount of time (a more 'user friendly' 60 seconds or so on mine), the AF box disappears. The first press of the AF/AE button brings the AF box back on screen but does not activate AF. A second press will then activate AF.

    It would appear that the camera puts several functions to sleep after this preset time period (Whilst keeping the screen/EVF active) and the first button press just wakes it from this semi- sleep mode. On my G5, I can also wake it with a half press of the shutter release, so that would be my work around.
     
    Last edited: Mar 17, 2015