1. Reminder: Please use our affiliate links to get to your favorite stores for holiday shopping!

GF1 Raw files problem - help request.

Discussion in 'Panasonic Cameras' started by Fiddler, Mar 14, 2011.

  1. Fiddler

    Fiddler Mu-43 Veteran

    Hi - I'm having a problem with the RAW files produced by my GF1, and would be grateful for any advice.

    I can't use any of the RAW files, and get a corrupted data error message when I try to open them. I've tried a couple of SD cards, so it's not a card problem.

    I can open RAW files from my G1 - no problem.

    I'm a Linux user, so the software I use is UFraw.

    I've tried Digikam and Raw Therapee as well - both of which should be able to open the files, but no success.

    Firmware on the cam is version 1.2.

    Maybe corrupted firmware?

    All the best,

    Colin
     
  2. grebeman

    grebeman Mu-43 All-Pro

    Mar 13, 2010
    South Brent, south Devon (UK)
    Barrie
    Hi Colin,

    Probably not much help, but I can confirm that UFraw running under Fedora 13 will happily open raw GF1 files. Have you been able to open GF1 raw files in the past with no problem?

    Barrie
     
    • Like Like x 1
  3. Fiddler

    Fiddler Mu-43 Veteran

    Thanks Barrie - I did manage to open some of them before, but now I can't open any. I can open the files from my G1, and as far as I know they are the same format. I guessing at a firmware problem, so I'll try reinstalling the firmware. Thanks again, Barrie.

    All the best,

    Colin
     
    • Like Like x 1
  4. soundimageplus

    soundimageplus Mu-43 Top Veteran

    782
    Feb 2, 2010
    Worcestershire
    Do they open in the supplied Silkypix software or Photoshop or Lightroom on a non-Linux computer? Have you tried formatting your SD cards from scratch? On the camera not on the computer. Are the 2 SD cards from the same batch? Bad ones tend to come in batches. Have you used the SD cards for any other purpose and in any other camera? Are all your current software programmes up to date? Did you buy the GF1 new? Did you install the firmware update?
    Lots of questions but it might be helpful in tracking the problem down.
     
    • Like Like x 1
  5. mauve

    mauve Mu-43 Top Veteran

    892
    Mar 9, 2010
    Paris, France
    Very strange. Linux user too here. Digikam uses libKdcraw internally (a rewrite of dcraw as a linkable library for the KDE project), ufraw is based on dcraw proper, and RawTherapee as far as I know is a rewrite of dcraw too, with proprietary algorithms thrown into the mix.

    If you have a functional compiling toolchain (gcc + linker + make), your best move would be to download dcraw source and compile latest rev. in your ~/ because it's a standalone application while others rely on libTiff to open files, and libTiff is a mess (and I'm polite here, my real opinion would rate this whole site +18).

    I don't believe your camera fw can cause such problems. But maybe data get jumbled in the download process. How do you copy your files to your computer ? Plugging the camera or with a SD reader ? Other option is a failing SD card. those beasts can be weird at times.

    PM if you need help.

    Cheers,
     
    • Like Like x 1