GF1 not showing B&W in Lightroom?

Discussion in 'Image Processing' started by andyw, Feb 5, 2010.

  1. andyw

    andyw Mu-43 Veteran

    410
    Jan 27, 2010
    Surrey. UK
    I took a couple shots on Aperture priority but before hand i pressed the Fn button on the back of the camera which bought up the film mode which I set to Dynamic B&W. Took 2 shots and imported them into Lightroom 2.5. When they came up they were in full normal colour! Why were they not in B&W ? Have I not done something? What's the point in having this feature if it does not show in Lightroom???? :D

    Any help appreciated.

    ooh by the way, i had a manual focus lens on, not my usual 20mm or 14-45mm AF lens. Dunno if this makes a difference?

    UPDATE:

    Ok i have just popped the 14-45mm on and it saves the image in dynamic B&W so that solves that mystery! :D

    I was going to delete this thread but it may help a few?
     
  2. Brian Mosley

    Brian Mosley Administrator Emeritus

    Dec 15, 2009
    Andy, were you shooting raw?

    The in-camera settings are unlikely to be recognised by a 3rd party raw converter. I don't know whether Panasonic gave Silkypix any better support?

    Cheers

    Brian
     
  3. andyw

    andyw Mu-43 Veteran

    410
    Jan 27, 2010
    Surrey. UK
    Yes i shoot in RAW. It happened because i was using a manual focus lens. It was fine with the Auto focus lens. I don't know why this should make any difference but hey ho! :smile:
     
  4. Brian Mosley

    Brian Mosley Administrator Emeritus

    Dec 15, 2009
    Are you expecting Lightroom to open your raw file, and display it in B&W if you had the camera in B&W mode for the capture?

    I don't know whether Lightroom will read the configuration settings in the raw file... and apply them by default to your raw file as it is opened. The raw file contains all of the colour data collected from the sensor... you'd need to apply a modifier to the raw file to make it B&W.

    Could it be, on previous attempts that you opened the B&W jpeg?

    Cheers

    Brian
     
  5. andyw

    andyw Mu-43 Veteran

    410
    Jan 27, 2010
    Surrey. UK
    I ALWAYS shoot in raw...no exceptions!

    The Dynamic B&W in camera setting works and opens just fine in lightroom if i use an AF lens. If i use an MF lens then the raw file opens in colour in lightroom.

    Dunno why having a MF lens on makes any difference but it must!
     
  6. Brian Mosley

    Brian Mosley Administrator Emeritus

    Dec 15, 2009
    That's interesting... is there anywhere you can get customer support / request a fix from Adobe?

    All of my raw converter suppliers will take a direct e-mail from me, and give me a personal reply... guess that's one of the reasons I steer clear of Adobe.

    Cheers

    Brian
     
  7. rst

    rst Mu-43 Regular

    109
    Jan 25, 2010
    Germany
    OK, maybe the G1 is a different story. But when I use Raw, then all my images, no matter which film mode I used open in color in Lightroom. When using a b&w mode in camera, then for a very short time Lightroom shows that b&w image. That is because they show the jpg file embedded in the Raw file until Lightroom has generated the standard previews (which are then in color). And this behavior is the same, no matter which lens I use (be it AF, or MF, adapted or zoom or prime). Since I think that handling of Raw files from G1 and GF1 should be pretty similar, I wonder why Adobe will handle them different. But hey, it is software, I work in IT myself, so I better not wonder why this is.

    Cheers
    rst
     
  8. Chow Monkey

    Chow Monkey Mu-43 Regular

    In Lightroom goto edit --> Preferences
    Goto import
    Enable "Treat JPG files next to RAW files as seperate photos

    This should solve the issue.. The Art Filters or the Themes in the Pana are not applied on the RAW file but saved as a seperate jpg as I was told..
     
    • Like Like x 2
  9. Brian Mosley

    Brian Mosley Administrator Emeritus

    Dec 15, 2009
    Ah, that makes sense Chow... thanks.

    Cheers

    Brian
     
  10. franzenjb

    franzenjb New to Mu-43

    2
    Jul 29, 2010
    Chow Monkey - huge help, problem plagued me for months.

    Thanks