1. Reminder: Please use our affiliate links for holiday shopping!

Genuine EM-5 Battery Inaccurate

Discussion in 'Olympus Cameras' started by marklikesit, Oct 3, 2012.

  1. marklikesit

    marklikesit Mu-43 Regular

    180
    Aug 8, 2012
    Sydney, Australia
    Mark Soon
    Hey guys,

    Just wanted some feedback here to see if you guys are having the same issues as I am.

    My battery meter, on many occasions has told me that I have either a full charge or 3/4 charge, and can drop instantly from full to 1/3 blinking red. This is so scary and annoying at the same time.

    Have I got a faulty battery?:confused:
     
  2. jnewell

    jnewell Mu-43 All-Pro

    Jun 23, 2011
    Boston, MA
    Mine has been a good bit more useful since I adjusted it in the menu, but no software battery meter I've used is very accurate. :redface:
     
  3. marklikesit

    marklikesit Mu-43 Regular

    180
    Aug 8, 2012
    Sydney, Australia
    Mark Soon
    Oh i didn't know you could adjust the battery meter in the menu?
     
  4. marklikesit

    marklikesit Mu-43 Regular

    180
    Aug 8, 2012
    Sydney, Australia
    Mark Soon
    Just found the setting. What do you set yours to Jnewell?
     
  5. Mikefellh

    Mikefellh Mu-43 Top Veteran

    939
    Jun 7, 2012
    Toronto, Canada
    Unfortunately, it's the nature of lithium-ion batteries to have a sudden dropoff.
     
  6. marklikesit

    marklikesit Mu-43 Regular

    180
    Aug 8, 2012
    Sydney, Australia
    Mark Soon
    Darn. That's scary. I thought only the 3rd party BLN-1's did this. Looks like the genuine ones do as well.