G85/80 reset problem

Macroramphosis

Mu-43 Veteran
Joined
Oct 29, 2018
Messages
429
Location
Charente Maritime, western France
Real Name
Roddy
I have a G80 I was recently gifted that I wish to reset to its default settings. I have followed the procedure as outlined in the manual and various places on-line, but my custom shooting settings (C1 and C2) and function buttons remain the same. I am having issues with the camera (as outlined in another thread) and think I may have received a demo unit which may have been been left with a fault, which is why I want to reset it.

At present when pressing the "Reset" button, I simply have my custom picture profile settings altered (along with Face settings and Profile). Nothing else changes. Am I doing something wrong? Is the camera not able to be reset totally to a "like new" condition?

All answers gratefully received.
 

Stanga

Mu-43 Top Veteran
Joined
Oct 16, 2016
Messages
937
Are you using the reset function in the menu? And is the camera asking you to set the time etc after the reset?
 

panamike

Mu-43 Hall of Famer
Joined
Jul 5, 2016
Messages
4,631
Location
Lincolnshire UK
This is the best i can find online

To reset the camera, you will need to carry out the following:
  1. Set the mode dial to P.
  2. Press the menu/set button.
  3. Select the setup option.
  4. Scroll through the setup listings until you get to 'reset'.
  5. Select the reset option to reset your camera.
Once the camera has reset, you will need to turn it off and back on again. You will then be prompted to set the date and time.
 

Macroramphosis

Mu-43 Veteran
Joined
Oct 29, 2018
Messages
429
Location
Charente Maritime, western France
Real Name
Roddy
Hi Mike - I have followed your instructions to the letter (just in case I have not been doing it right before), and I still do not find anything reset apart from the four options in the Custom Picture Style. Nothing else changes and I do not get any further prompts.

I have been in touch with the UK shop who sold the camera, and they are going to contact Panasonic UK to try and resolve the issue. We'll see what happens.

Taking pictures of my little one this morning at tennis I had to put the G80 down and shoot with the G6 to have any success. I was shooting in One Area, AFS and the Focus Peaking colours kept appearing - I am sure that is not normal! :)
 
Last edited:

Bushboy

Mu-43 Top Veteran
Joined
Apr 22, 2018
Messages
799
Location
Aotearoa
Real Name
Charlie
What a shame. Especially as it was a gift.
Best of luck! Hope it gets sorted for you.
 

Wasabi Bob

Mu-43 All-Pro
Joined
Nov 23, 2010
Messages
1,091
Location
New Jersey - United States
RESET is a firmware function. I've worked at service centers and never seen this. When you do a reset, it asks you several questions to which you select yes or no. I seriously doubt this is a repair issue. I just tried it on my G9 and the "C" buttons are not reset, nor did I have to reset the clock. I do recall that on an earlier G series camera they made a firmware update NOT to reset the custom settings. If you want to change them, simply reconfigure camera as you want it and resave over an existing custom setting.
 

Latest posts

Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Mu-43 is a fan site and not associated with Olympus, Panasonic, or other manufacturers mentioned on this site.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Copyright © 2009-2019 Amin Forums, LLC
Top Bottom