1. Welcome to Mu-43.com—a friendly Micro 4/3 camera & photography discussion forum!

    If you are thinking of buying a camera or need help with your photos, you will find our forum members full of advice! Click here to join for free!

fuzzy lcd on EP-2?

Discussion in 'Olympus Cameras' started by snapbug, Jan 31, 2012.

  1. snapbug

    snapbug Mu-43 Rookie

    24
    Jan 1, 2012
    Seattle
    So this is probably a newb question, but I haven't been able to figure this one out. Just got my EP-2. It's my first "real" camera. I have the stock 14-42mm zoom and a Panny 20mm.

    My question is this: in Manual mode, when I depress the shutter button to use the auto focus feature, the camera briefly shows me what the photo will look like, in terms of exposure, then the lcd goes white and grainy. And when I say briefly, I mean briefly, like for a fraction of a second. This isn't really long enough to tell if my exposure works or not. I have to hit the button again... and again... and still, I can't study it.

    I don't have a viewfinder, but I wouldn't expect to "need" one in this sense. Even my cheapy little point-and-shoot would adjust to my exposure and hold it until I depressed the button all the way. I don't have another $200 at the moment for the viewfinder.

    Thoughts? Is this just a feature of these cameras? Is there something I'm doing wrong? I don't get it.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.