1. Reminder: Please use our affiliate links for holiday shopping!

Forum skin changed?

Discussion in 'Help and Feedback' started by MarkRyan, Mar 29, 2016.

  1. MarkRyan

    MarkRyan Instagram: @MRSallee

    772
    May 3, 2013
    California
    Seems the forum skin options changed the other day. Now there's bold text everywhere, which is...quite poor visual design. Am I missing something?
     
  2. ijm5012

    ijm5012 Mu-43 Hall of Famer

    Oct 2, 2013
    Pittsburgh, PA
    Ian
    Yes, @Amin Sabet@Amin Sabet did consolidate the skins down to two; a light and a dark one. But I'm not seeing the bold text like you are.

    What skin are you using? FWIW, I'm using the dark skin.
     
    • Informative Informative x 1
    • Appreciate Appreciate x 1
  3. Amin Sabet

    Amin Sabet Administrator

    Apr 10, 2009
    Boston, MA (USA)
    Please post a screenshot if possible, showing where you see the excessive bold texting so I can tell if you're seeing something I'm not seeing.
     
  4. MarkRyan

    MarkRyan Instagram: @MRSallee

    772
    May 3, 2013
    California
    Using the latest build of Chrome.

    Screen Shot 2016-03-29 at 7.52.22 AM.

    Screen Shot 2016-03-29 at 7.52.42 AM.
     
  5. Amin Sabet

    Amin Sabet Administrator

    Apr 10, 2009
    Boston, MA (USA)
    This is what I'm seeing, also in the latest build of Chrome. It bolds forums and threads which contain unread posts, which is the same behavior as our old forum skin.

    bolded.
     
    • Agree Agree x 1
    • Appreciate Appreciate x 1
  6. tkbslc

    tkbslc Mu-43 Hall of Famer

    @MarkRyan@MarkRyan You didn't accidentally set a custom font in Chrome settings, did you? If it looks different in another browser, change your chrome settings to default. Mine looks like Amin's screenshot
     
  7. MarkRyan

    MarkRyan Instagram: @MRSallee

    772
    May 3, 2013
    California
    I think I know what's happening. The font specified by the forum is Lato, but there's no Lato being loaded by the skin. I happen to have Lato installed on my computer, but only the black weight version. So everything is appearing for me in black weight because I happen to have Lato on my machine :)

    @Amin Sabet@Amin Sabet, your screenshot shows that you're not getting the Lato font, which confirms my suspicion that the skin is specifying a font it doesn't load.

    Google Fonts Lato
     
    • Informative Informative x 1
  8. MarkRyan

    MarkRyan Instagram: @MRSallee

    772
    May 3, 2013
    California
    There, I just installed a regular weight for Lato.

    Screen Shot 2016-03-29 at 8.18.46 AM.
     
  9. j9ksf

    j9ksf Mu-43 Rookie

    16
    Jun 20, 2013
    I had the same problem with Waterfox.
     
  10. jimr.pdx

    jimr.pdx Mu-43 Veteran

    342
    Dec 5, 2010
    near Longview ~1hr from PDX
    Jim R
    I noted that on my tablet it's not at all easy to see which page I'm on for a multi-page topic. All the page numbers looked nearly identical but close scrutiny showed a small highlight. That too would have been a Chrome view.

    edit - comment relates to dark skin
     
    Last edited: Mar 29, 2016
  11. Amin Sabet

    Amin Sabet Administrator

    Apr 10, 2009
    Boston, MA (USA)
    Thanks, very helpful! The forum style gives me the following font options. Would appreciate advice. Should I take Lato out altogether? Leave it alone? Replace Laco with Verdana (like the old style)? I was told that enabling Google web fonts could slow performance, but willing to go that route also if it would look better.

    fonts.
     
  12. SVQuant

    SVQuant Mu-43 Top Veteran

    851
    Sep 20, 2015
    SF Bay Area, California, USA
    Sameer
    Leaving Lato in is not a problem. If you don't have it installed, the style will default to Arial or the default sans-serif on Macs. I think that Mark's issue arose from having only a single weight of Lato installed on his computer.

    FWIW, if you were to check the "Enable Web Fonts" box in the screenshot you posted and paste in the corrent weblink for Lato, the font will download to user's computer or device.
     
    • Appreciate Appreciate x 1
  13. Amin Sabet

    Amin Sabet Administrator

    Apr 10, 2009
    Boston, MA (USA)
    Better, now?
     
  14. MarkRyan

    MarkRyan Instagram: @MRSallee

    772
    May 3, 2013
    California
    Both Lato and Verdana are solid types, your preference is as good as any. Enabling Google Fonts will add another ~150kb to page load, but it should cache which means only the first page load will see the performance hit. If you don't enable Google Fonts, I suggest removing the Lato references, though like @SVQuant@SVQuant mentioned it won't matter for most users since Lato isn't a common font to have installed.
     
  15. Amin Sabet

    Amin Sabet Administrator

    Apr 10, 2009
    Boston, MA (USA)
    @MarkRyan@MarkRyan - Do you thing Verdana, Arial is better than just Arial? I personally prefer Verdana. As you said, most people won't have Laco. I'd rather leave off Google Fonts for now.
     
  16. jimr.pdx

    jimr.pdx Mu-43 Veteran

    342
    Dec 5, 2010
    near Longview ~1hr from PDX
    Jim R
    Yes Amin, much better :)
    The rusty red was nice (briefly) but the blue highlights look good too.

     
  17. Speedliner

    Speedliner Mu-43 All-Pro

    Mar 2, 2015
    Southern NJ, USA
    Rob
    Please change the name of this thread. Please.
     
    • Winner Winner x 2
    • Funny Funny x 1
  18. SVQuant

    SVQuant Mu-43 Top Veteran

    851
    Sep 20, 2015
    SF Bay Area, California, USA
    Sameer
    I'll chime in even though this wasn't directed at me. I am one of those rare people who had Lato installed already (using it on my sites as well) and like how it looks. If you want to leave google fonts off, then could I request that you do Lato, Verdana, Arial? I think the site looked good with Verdana.

    As regard performance, on my servers Lato takes just under 40ms to load the first time and is cached after that. So I don't think that the performance hit is too bad and is certainly not an issue for regular site users whose font cache will not expire between visits. On an image heavy site like this, it would likely not even be noticeable the first time.
     
    • Appreciate Appreciate x 1
  19. Amin Sabet

    Amin Sabet Administrator

    Apr 10, 2009
    Boston, MA (USA)
    Can you tell me the correct weblink for Lato? Thanks!

    Edit: Nevermind, found it!
     
  20. SVQuant

    SVQuant Mu-43 Top Veteran

    851
    Sep 20, 2015
    SF Bay Area, California, USA
    Sameer
    For regular and bold weights:
    <link href='https://fonts.googleapis.com/css?family=Lato:400,700' rel='stylesheet' type='text/css'>

    For italics as well (not sure if this site uses them):
    <link href='https://fonts.googleapis.com/css?family=Lato:400,700,400italic,700italic' rel='stylesheet' type='text/css'>

    Remove the 700italic if you do not need bold+italic. Google estimates about 25ms per font style for this font. My testing is showing around 18-20ms consistently.