1. Reminder: Please user our affiliate links to get to your favorite stores for holiday shopping!

FL500 Flash with G2?

Discussion in 'Panasonic Cameras' started by antifuse, Jun 9, 2011.

  1. antifuse

    antifuse Mu-43 Regular

    36
    Mar 9, 2011
    Not sure if anybody else has experienced this... I had my first chance yesterday to try out my FL500 with my G2 (at a wedding)... And it seems like the FL500 is just not recognizing that it's connected to the camera. Or rather, it's recognizing that it's connected (flashes when the picture is taken, etc) but it is not recognizing the camera's settings. It isn't recognizing any of the camera's settings (no recognition of focal length, for instance). And as a result, I'm not convinced that TTL is actually functioning properly. The shots are a big reason for me suspecting this, as they turned out... Less than stellar. I'm coming from a Nikon D300 with Nikon's external flash system, which was pretty brainless to use, so maybe I'm just missing some sort of setting/functionality? I guess I'm going to have to pore through the manual for the FL500, but was hoping that somebody else had experience with this.
     
  2. antifuse

    antifuse Mu-43 Regular

    36
    Mar 9, 2011
    Ok, so I figured it out - it only shows the camera info (zoom level, etc) when the flash is pointing straight forward. If you've got it pointing up (for bounce flash, with a Gary Fong, etc) it doesn't show any camera info. That's a relief, at least. Now I just need to figure out why the TTL results seem to be so all over the place.