FL-300 Slave difficulty

Discussion in 'Open Discussion' started by JonathanS, Oct 17, 2011.

  1. JonathanS

    JonathanS Mu-43 Rookie

    17
    Nov 13, 2010
    I tried utilizing my FL300 as a remote slave flash with my EP3 today. Flash fired OK, but all my shots were severely underexposed, even when I compensated to +3 stops.

    I thought I'd make sure my flash setting was on full, rather than fill, but for some reason I can't get it set to Full. Its grayed out in all modes (P, A, S).

    In some setups (for Stellar Jays) the FL300 was only four feet from the subject, yet still was weak. ISO I used was from 800 up to 2000. Yes, I made sure the slave was firing. Any help would be appreciated. I'm hoping I missed a setting somewhere.
     
  2. RobWatson

    RobWatson Mu-43 Hall of Famer

    Exposure time? Sync speed? EV comp won't help ...
     
  3. JonathanS

    JonathanS Mu-43 Rookie

    17
    Nov 13, 2010
    According to the manuals there is a dedicated screen for controling a wireless slave. For some reason I'm not able to figure out how to get there.
    Help!
     
  4. starlabs

    starlabs Mu-43 Top Veteran

    856
    Sep 30, 2010
    Los Angeles
    Make sure you turn RC on for *both* the camera and the flash itself (it's a switch on the flash, just set it to RC bank A).

    Did you turn on the Super Control Panel? Once you're at the SCP screen, press the Info button to switch to different screen modes. It should eventually change to the RC Flash screen.
     
  5. JonathanS

    JonathanS Mu-43 Rookie

    17
    Nov 13, 2010
    Thanks Starlab,
    Turning on the SCP did the trick!