Firmware update

robert sands

New to Mu-43
Joined
May 21, 2019
Messages
1
It appears that Olympus has a software glitch for downloading 3.0 firmware, (at least for the M1)
Has anyone heard when the 3.0 will be available for downloading ?
 

Growltiger

Mu-43 All-Pro
Joined
Mar 26, 2014
Messages
1,919
Location
UK
You don't say which camera you have. This page tells you which version you can update to: Joint update service for OLYMPUS E-SYSTEM - OLYMPUS Digital Camera

If you have the EM1 II then vast numbers of people have updated to V3 but if you have a different camera then it will be a different version that you can get, if you are not already up to date.

Nowadays the easy way to update is to install Olympus Workspace, update that software first (currently to V1.1) and then use it to update your camera and lens. It really is easy if you follow the instructions.
 
Joined
Oct 4, 2015
Messages
433
Location
PA, USA/Sydney, Australia
Does anyone know if this will be Olympus’ preferred method for updating their cameras and lenses moving forward. It seems that their current Camera Updater software is not 64 bit and is not compatible with future Mac OS releases. At least that is the message that appears each time I open the software on my MacBook Pro.
 

jab7107

New to Mu-43
Joined
Sep 19, 2019
Messages
6
Location
Whitby, North Yorkshire, UK
Real Name
John A Birch
I have been tying for days to update my E-M10 mark ii and my E-M5 mark ii on the latest Olympus Workspace on a Windows 64bit laptop. The computer and the camera showed that a good connection had been made but initiating the the camera uploaded a message of "the camera cannot be detected" and shuts down the process. As Olympus has made the workspace as the only method of updating, that I can find, how can I get over this problem?

Any help or direction would be gratefully received.

John
 

Growltiger

Mu-43 All-Pro
Joined
Mar 26, 2014
Messages
1,919
Location
UK
Did you remember to press OK on the camera after you connected the cable?
 

jab7107

New to Mu-43
Joined
Sep 19, 2019
Messages
6
Location
Whitby, North Yorkshire, UK
Real Name
John A Birch
It does not ask you to press OK on the olympus workplace camera update, it asks you to, connect camera then press next on the upload screen, when you do this it comes up with a message that the camera cannot be detected, and asked you to cancel the process every time.

I have tried to download the stand alone camera update but it just directs you to workspace. Dose anyone know how to update any other way, is anyone else having problems updating with workspace, or has anyone managed to solve the problem. Help please.
 

Growltiger

Mu-43 All-Pro
Joined
Mar 26, 2014
Messages
1,919
Location
UK
You didn't understand me.
You have to press the button ON THE CAMERA.
 

jab7107

New to Mu-43
Joined
Sep 19, 2019
Messages
6
Location
Whitby, North Yorkshire, UK
Real Name
John A Birch
Thank you both,
Updated the e-m10 mark ii on the lightning site but updated the e-m5 mark ii and the e-m1 on the workspace updater (after pressing the OK button, thank you). All cameras up to date, happy chappy.

Manny thanks

John
 
Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Mu-43 is a fan site and not associated with Olympus, Panasonic, or other manufacturers mentioned on this site.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Copyright © 2009-2019 Amin Forums, LLC
Top Bottom