Firmware Update - this is wierd!

Discussion in 'Olympus Cameras' started by slothead, Jun 13, 2013.

  1. slothead

    slothead Mu-43 All-Pro

    Aug 14, 2012
    Frederick, MD
    Several months ago, at the suggestion here on the Mu43, I updated my OM-D E-M5 to the latest firmware 1.6. I just checked my camera to confirm that firmware revision number. Now however, when I go to Olympus Corporate site, I don't see the 1.6 version. It implies that 1.5 is the most recent.

    I have two E-M5s. My older one is the one I upgraded (and it still says camera body 1.6), while the newer one I have has not been upgraded beyond version 1.5 and shows that in the firmware rev. I was going to upgrade the new er one to 1.6, but I sure can't find it now!

    Am I nuts? Or what is going on?
     
  2. jnewell

    jnewell Mu-43 All-Pro

    Jun 23, 2011
    Boston, MA
    I think what's going on is that they just released v.1.7 for the EM-5...? Not worth the upgrade effort for the EM-5, IMO, but I'd be interested in arguments to the contrary. :)
     
  3. slothead

    slothead Mu-43 All-Pro

    Aug 14, 2012
    Frederick, MD
    Ok, so why then doesn't 1.7 show up on the firmware page?
     
  4. dhazeghi

    dhazeghi Mu-43 Hall of Famer

    Aug 6, 2010
    San Jose, CA
    Dara
    They're slow.

    IIRC 1.6 was a special release to fix a but in the 1.5 updater that resulted in some folks bricking their cameras. Note that 1.6 contained no functional changes for the camera, so if you successfully installed 1.5, there was no reason to upgrade.
     
  5. slothead

    slothead Mu-43 All-Pro

    Aug 14, 2012
    Frederick, MD
    Thanks dhazeghi, I didn't realize that 1.6 was a temp. Now I'll just be patient and wait for them to post 1.7.
     
  6. Mikefellh

    Mikefellh Mu-43 Top Veteran

    939
    Jun 7, 2012
    Toronto, Canada
    Always look on the Japanese (head office) site for the latest info, the other sites can be behind. Here's the link:
    Joint update service for OLYMPUS E-SYSTEM - OLYMPUS Digital Camera

    Version 1.7 has been available since the 12th.

    BTW, it was 1.3 (not 1.6) that was the fix for people bricking their camera with 1.2...still say it was user error since I didn't have an issue with either of my two E-M5's. Everything after had no issues.
     
  7. DHart

    DHart Mu-43 Hall of Famer

    Jan 7, 2010
    Scottsdale, Arizona
    Don
    As a happy camera with 1.5 on my E-M5, is there enough benefit in 1.6 or 1.7 to motivate one to bother with an upgrade?
     
  8. macboy001

    macboy001 Mu-43 Regular

    29
    Jun 25, 2010
    Wairarapa, New Zealand
    Has anybody successfully upgraded their E-M5 from 1.6 to 1.7? I'm using the updater on my Mac, I get as far as dialogue box with the circle with the hand through it (but that takes about 5 minutes to get there) and then it claims to loading the firmware and gets no further - I've given it 20 minutes and nothing. Luckily I haven't bricked it. I've tried full resetting the camera, reformatted the SD card. The digital updater takes me through to the close screen and exits cleanly but the cameras firmware is still 1.6.
     
  9. agpr

    agpr Mu-43 Regular

    153
    Nov 2, 2010
    Heraklion, Crete
    Yeap, I updated from 1.6 to 1.7 without a problem.
    As a computer nerd I feel the urge to update all of my devices just because I can.
     
  10. macboy001

    macboy001 Mu-43 Regular

    29
    Jun 25, 2010
    Wairarapa, New Zealand
    Ok I got it to work, I rebooted my Mac and tried again, pretty disappointing having to apply part of the Windows diagnostic routine to the software - restart/reboot/reinstall ;-)
     
  11. jnewell

    jnewell Mu-43 All-Pro

    Jun 23, 2011
    Boston, MA
    I did upgrade to 1.6, though I don't remember why. :rolleyes: 1.7, however, looks like it only adds EVF4 support, which seems useless for the EM-5...at least IMHO. :smile:
     
  12. jnewell

    jnewell Mu-43 All-Pro

    Jun 23, 2011
    Boston, MA
    I was seeing it on their update page yesterday...still there today... :confused: :smile:
     
  13. slothead

    slothead Mu-43 All-Pro

    Aug 14, 2012
    Frederick, MD
    OK, I give up. Where did you find 1.7? It isn't on the Oly corporate E-M5 support page. Please let me know.
     
  14. RobWatson

    RobWatson Mu-43 Hall of Famer

    I can only see v1.1 & v1.2!
     
  15. rich9cinti

    rich9cinti Mu-43 Veteran

    288
    Mar 23, 2013
    Cincinnati, Ohio
    Rich
    Just rec'd my OM-D today, firmware is 1.6 Should I go to 1.7 or not?
     
  16. RobWatson

    RobWatson Mu-43 Hall of Famer

  17. jnewell

    jnewell Mu-43 All-Pro

    Jun 23, 2011
    Boston, MA
  18. RobWatson

    RobWatson Mu-43 Hall of Famer

  19. DHart

    DHart Mu-43 Hall of Famer

    Jan 7, 2010
    Scottsdale, Arizona
    Don
    Thanks, buddy... I think won't fix what ain't broken! :wink: And stick with 1.5 until something really compelling comes along. :smile:
     
  20. Mikefellh

    Mikefellh Mu-43 Top Veteran

    939
    Jun 7, 2012
    Toronto, Canada
    After you previously posted in this thread (reply #5) I replied (reply #6) with a link telling you EXACTLY where to get the information on Olympus firmware on the head office site. If you're not going to read the replies.... :confused:

    Link to reply #6