FD Lens Issue - Help Please...

Discussion in 'Adapted Lenses' started by demiro, Feb 9, 2011.

  1. demiro

    demiro Mu-43 All-Pro

    Nov 7, 2010
    I just picked up a beautiful Canon FD 50/1.4 SSC lens. It is the older breech-lock style with silver ring at mount end of lens. I have read a bit about how aperture cannot be adjusted unless lens is mounted, as I initially thought the lens was stuck in the wide open position.

    What I am seeing on camera is no difference when I adjust aperture manually, from 1.4 all the down to 16. I've read some more about these lenses, and see that I should be able to lock the larger lever on lens and then be able to control aperture manually, but that does not work either.

    Any ideas? I have a Fotodiox adapter, which has the little notch for pin built in, and I've tried it with the lock/open ring on adapter turned both ways - no difference.

    Lens is still pretty sweet just in wide open position, but I'd obviously like to see what it can do stopped down as well.

    Any ideas would be greatly appreciated!
  2. OPSSam

    OPSSam Mu-43 Regular

    Dec 18, 2010
    I have the same type of lens (50mm 1.8 FD). There should be some manner of lever on the back of the lens that will lock down the aperture. I'd make sure the lever works when not connected to the camera. Put it on 16 and move that lever. If there is no change you may have a problem.

    My lens' lever got the aperture stuck closed the other day, but a little pressure and it went back to nomal.
  3. Luckypenguin

    Luckypenguin .

    Oct 9, 2010
    Brisbane, Australia
    Real Name:
    It's a common enough problem on the early FD lenses - a few forum members have reported similar problems. Depending how good you are at tinkering it is relatively easy to remove the back of a FD breech-lock lens and "reset" the diaphragm blades. As always it is the putting it back together that is a little more difficult. I recently repaired a 50mm f1.4 SSC that was stuck wide open but it turned out that this particular example which was pretty bad at f1.4 in the first place wasn't a great deal better at smaller apertures either.
  4. demiro

    demiro Mu-43 All-Pro

    Nov 7, 2010
    That lever does not allow me to control it. I've tried it in both positions, and in the middle.

    I will have to Google up some instructions. I'd hate to completely destroy this lens though...
  5. photoSmart42

    photoSmart42 Mu-43 Top Veteran

    Feb 12, 2010
    San Diego, CA
    The aperture lever only works if the breech lock is engaged. To do that with the lens not mounted, you need to push in the small pin by the red dot on your lens mount, and twist the breech lock as if mounting the lens. At that point you can try moving the aperture lever and see if your aperture opens and closes properly. If that doesn't work, then you'll know you have a stuck aperture.
    • Like Like x 1