FD Adapter fits on E-PL1 but not on E-P3

Discussion in 'Adapted Lenses' started by TeeHeeHaw, Oct 19, 2011.

  1. TeeHeeHaw

    TeeHeeHaw Mu-43 Rookie

    Aug 31, 2011
    Central Ohio
    I have the Fotasy FD adapter for my 50mm F1.4 Canon Lens and have been using it for a while on my E-PL1. MY E-P3 was away for repairs and now that I finally have it back I can't get the adapter to fit. If I start turning it to lock it into position, it begins to grind and the resistance is too great. In addition, the grinding causes paint to shave off which could get on the sensor.

    This also happened on the first E-P3 I had. The one I am using now is a replacement.

    Has anyone else experienced something similar? Any recommendations for a good adapter with aperture control?
  2. Mellow

    Mellow Mu-43 All-Pro

    Aug 27, 2010
    Florida or Idaho
    Real Name:
    Interesting. I sold a C-mount adapter to a guy on eBay a couple of weeks ago and he reported the same thing--he couldn't get it to fit on his E-P3, when I know it fit fine on my E-PL1. It appears maybe that the E-P3 mount is a little tighter than previous ones? I'm pretty sure he could have made it fit if he'd just turned a little harder, but I sent him another adapter that had a 'sloppy' fit on my camera, and he reported it fit perfectly.

    I hesitate to recommend just 'twisting harder' but I'm 95% sure that would work. Grinding off paint, OTOH, doesn't sound good. And then there's that residual 5% . . .

    Can't offer much advice, except to observe that you don't appear to be alone.
  3. Ned

    Ned Mu-43 Legend

    Jul 18, 2010
    Alberta, Canada
    My E-3 mount is really tight like that, but that's only because the plate got warped from a drop once. Perhaps they are intentionally making the E-P3 mount that tight now. I coincidentally noticed last night that there was an awful lot of play in my E-PL2 with OM Zuiko 50mm combination, so I started unscrewing each piece (OM lens, OM-to-4/3 adapter, 4/3-to-m4/3 adapter) to see where the play was coming from. It was in the Micro Four-Thirds adapter end... so perhaps other people were noticing how loose the mount was?
  4. TeeHeeHaw

    TeeHeeHaw Mu-43 Rookie

    Aug 31, 2011
    Central Ohio
    Well, that's good to know I'm not the only one that experienced this issue.

    Looks like I'll basically have to use the EPL1 if I want to use the Canon FD lens. I was planning on selling the EPL1 soon. I haven't used the FD lens in a while so it's not a big loss (the new 45 f1.8 is keeping me occupied ATM...lol).
  5. JoeBoke

    JoeBoke New to Mu-43

    Nov 2, 2011
    Parker, CO
    I am considering this same set up for environmental and candid portraits, can you share which adapters you are currently using and or recommend? I am a new enthusiast photographer on a budget and have really been loving my E-PL2 kit, but looking for some additional lens options that will expand my abilities without crushing my wallet. Thanx in advance.