1. Reminder: Please user our affiliate links to get to your favorite stores for holiday shopping!

Faulty EM-10 - black live view image

Discussion in 'Olympus Cameras' started by Levster, Dec 29, 2014.

  1. Levster

    Levster Mu-43 Top Veteran

    My new (refurbished) EM-10 has developed a fault after a few minutes of use and I was wondering if anyone here had seen and fixed this fault before. I am running V1.1 firmware and after shooting a few shots with my 45mm f/1.8 I turned the camera off and put my 15mm f/1.7 on. When I turned the camera back on I was presented with the live view screen but the image was black (as if the lens cap was on), however the aperture value shows -.- and when I try the EVF I get the same thing. I've tried all of my lenses and the symptom is the same, and all lenses work just fine on my EM-1. I'm well within the returns period but before returning is it worth a firmware upgrade or does this sound terminal?
     
  2. Plumballs

    Plumballs Mu-43 Veteran

    215
    Jul 11, 2014
    Whitchurch, Hampshire
    Phil
    To me it seems as the connectors on the camera body are not happy the lens is clicked into place properly. I have had the weird black screen effect, i took the lens off put it back on making sure it clicked into place and all was ok again. Check and clean your sensors on the body it might do the trick.

    Phil
     
  3. eteless

    eteless Mu-43 All-Pro

    Jun 20, 2014
    Does it work with no lens on? It sounds like the lock pin that stops the lens rotating may be stuck pressed in or the switch is faulty.
     
  4. Levster

    Levster Mu-43 Top Veteran

    If I remove the lens completely the live view does display an image. It sounds as though the lens contacts are not working properly as I had a similar issue with a third party MMF-2 adapter. With the adapter I was able to wiggle it a bit and it worked, but this mount is so tight that there is no give at all. I'm starting to think that sending it back would be the best idea.
     
  5. Mikefellh

    Mikefellh Mu-43 Top Veteran

    939
    Jun 7, 2012
    Toronto, Canada
    DON'T HOLD THE LENS RELEASE BUTTON WHEN ATTACHING LENSES!!!

    If you hold the lens RELEASE button down when attaching a lens, the lens will turn PAST the lens locking point and you will get the black screen. Let the lens push the locking pin in, and listen for the click when the lens locks.

    If you do get this try turning the lens in the opposite direction WITHOUT PRESSING THE LENS RELEASE BUTTON.
     
  6. Levster

    Levster Mu-43 Top Veteran

    I've never really thought about holding the lens release button whilst attaching the lens, but to be sure I've tried it again whilst definitely not holding the lens release button, it doesn't make a difference unfortunately. There really is no give on the mount once the lens has clicked into place and twisting the lens does not make any difference.